summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-08-12 16:48:10 +0200
committersl1pkn072015-08-12 16:48:10 +0200
commita257ad9a9914f9012c01dd0eacc2e9cdc05660fe (patch)
tree45db46c88f489448041f4f11b1146f3443003248
parente7971f782ea9b149da9afd0f8715b58b8a896d70 (diff)
downloadaur-a257ad9a9914f9012c01dd0eacc2e9cdc05660fe.tar.gz
Update to 0.164
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
-rw-r--r--sdlmame-wout-toolkits.install44
3 files changed, 62 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fe4e5a94e02..94a423f88acf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sdlmame-wout-toolkits
pkgdesc = A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit
- pkgver = 0.162
- pkgrel = 2
- url = http://mamedev.org/
+ pkgver = 0.164
+ pkgrel = 1
+ url = http://mamedev.org
install = sdlmame-wout-toolkits.install
arch = i686
arch = x86_64
@@ -14,13 +14,18 @@ pkgbase = sdlmame-wout-toolkits
makedepends = python2
depends = sdl2_ttf
depends = alsa-lib
+ depends = lua
+ depends = flac
+ depends = portmidi
+ depends = libjpeg-turbo
+ depends = sqlite
conflicts = sdlmame
conflicts = sdlmamefamily-tools
noextract = extras.tar.gz
- source = https://github.com/mamedev/mame/archive/mame0162.tar.gz
+ source = https://github.com/mamedev/mame/archive/mame0164.tar.gz
source = sdlmame.sh
source = extras.tar.gz
- sha1sums = 1d44bddea9cd4bb1d683f0ea1788a02e2f18e185
+ sha1sums = bb6379ff2257ced39e21f154e16b819e53edb4d1
sha1sums = 1ed8016f41edecfca746fadcfb40eab78845a3d6
sha1sums = 75732974431844670aa3904d8f9ce3f5c5504827
diff --git a/PKGBUILD b/PKGBUILD
index 0cb6f2b3fa26..358a34d9b732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,35 @@
# Based On: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=sdlmame-wout-toolkits
-pkgver=0.162
-pkgrel=2
+pkgver=0.164
+pkgrel=1
pkgdesc="A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit"
-url="http://mamedev.org/"
+url='http://mamedev.org'
license=('custom:MAME License')
arch=('i686' 'x86_64')
conflicts=('sdlmame' 'sdlmamefamily-tools')
-depends=('sdl2_ttf' 'alsa-lib')
-makedepends=('nasm' 'mesa' 'glu' 'wget' 'python2')
+depends=('sdl2_ttf'
+ 'alsa-lib'
+ 'lua'
+ 'flac'
+ 'portmidi'
+ 'libjpeg-turbo'
+ 'sqlite'
+ )
+makedepends=('nasm'
+ 'mesa'
+ 'glu'
+ 'wget'
+ 'python2'
+ )
source=("https://github.com/mamedev/mame/archive/mame${pkgver/./}.tar.gz"
- "sdlmame.sh"
- "extras.tar.gz")
-sha1sums=('1d44bddea9cd4bb1d683f0ea1788a02e2f18e185'
+ 'sdlmame.sh'
+ 'extras.tar.gz')
+sha1sums=('bb6379ff2257ced39e21f154e16b819e53edb4d1'
'1ed8016f41edecfca746fadcfb40eab78845a3d6'
'75732974431844670aa3904d8f9ce3f5c5504827')
install=sdlmame-wout-toolkits.install
-noextract=("extras.tar.gz")
+noextract=('extras.tar.gz')
prepare() {
cd "mame-mame${pkgver/./}"
@@ -40,9 +52,16 @@ build() {
NOWERROR=1 \
USE_OPENGL=1 \
USE_QTDEBUG=0 \
- TESTS=0 \
TOOLS=1 \
- STRIP_SYMBOLS=1
+ STRIP_SYMBOLS=1 \
+ VERBOSE=1 \
+ USE_SYSTEM_LIB_EXPAT=1 \
+ USE_SYSTEM_LIB_ZLIB=1 \
+ USE_SYSTEM_LIB_JPEG=1 \
+ USE_SYSTEM_LIB_FLAC=1 \
+ USE_SYSTEM_LIB_LUA=1 \
+ USE_SYSTEM_LIB_SQLITE3=1 \
+ USE_SYSTEM_LIB_PORTMIDI=1
}
package() {
@@ -51,9 +70,9 @@ package() {
# Install the sdlmame script
install -Dm755 ../sdlmame.sh "${pkgdir}/usr/bin/sdlmame"
+ # Install the applications and the UI font in /usr/share
[ "${CARCH}" = "i686" ] && _suffix=""
[ "${CARCH}" = "x86_64" ] && _suffix="64"
- # Install the applications and the UI font in /usr/share
install -Dm755 "mame${_suffix}" "${pkgdir}/usr/share/sdlmame/sdlmame"
# Install the applications
@@ -75,10 +94,6 @@ package() {
install -Dm755 unidasm "${pkgdir}/usr/bin/unidasm"
# Install the extra bits
- install -d "${pkgdir}/usr/share/man/man1"
- install -m644 src/osd/sdl/man/*.1* "${pkgdir}/usr/share/man/man1/"
-
- # Install the extra bits
install -d "${pkgdir}/usr/share/sdlmame/"{artwork,ctrlr,keymaps,shader}
install -m644 artwork/* "${pkgdir}/usr/share/sdlmame/artwork/"
install -m644 ctrlr/* "${pkgdir}/usr/share/sdlmame/ctrlr/"
@@ -86,19 +101,19 @@ package() {
install -m644 src/osd/modules/opengl/shader/glsl*.*h "${pkgdir}/usr/share/sdlmame/shader/"
# Install man
+ (cd src/osd/sdl/man/; for i in $(find . -type f -name '*.1'); do install -Dm644 "${i}" "${pkgdir}/usr/share/man/man1/${i}"; done)
install -Dm644 src/osd/sdl/man/mame.6 "${pkgdir}/usr/share/man/man6/sdlmame.6"
# Include the license
install -Dm644 docs/mamelicense.txt "${pkgdir}/usr/share/licenses/${pkgname}/mamelicense.txt"
+ # documentation
+ (cd docs; for i in $(find . -type f); do install -Dm644 "${i}" "${pkgdir}/usr/share/doc/${pkgname}/${i}"; done)
+
# FS#28203
sed -e 's|KEYCODE_2_PAD|KEYCODE_2PAD|' \
-e 's|KEYCODE_4_PAD|KEYCODE_4PAD|' \
-e 's|KEYCODE_6_PAD|KEYCODE_6PAD|' \
-e 's|KEYCODE_8_PAD|KEYCODE_8PAD|' \
-i "${pkgdir}/usr/share/sdlmame/ctrlr/"*.cfg
-
- # documentation
- cd docs
- for i in $(find . -type f); do install -Dm644 "${i}" "${pkgdir}/usr/share/doc/${pkgname}/${i}"; done
}
diff --git a/sdlmame-wout-toolkits.install b/sdlmame-wout-toolkits.install
index 874ca78b072c..ceda91ade1a5 100644
--- a/sdlmame-wout-toolkits.install
+++ b/sdlmame-wout-toolkits.install
@@ -1,29 +1,19 @@
-# Message displayed for a fresh install.
-post_install()
-{
- echo ""
- echo "***************************************************************"
- echo " SDLMAME and the additional MAME utilities have been installed"
- echo " in /usr/share/sdlmame However, SDLMAME can be run by"
- echo " typing sdlmame and it's options. Try running SDLMAME with"
- echo " these options:"
- echo " sdlmame <rom> -nowindow -noswitchres"
- echo "***************************************************************"
- echo ""
-}
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+yellow="${bold}$(tput setaf 3)"
+blue="${bold}$(tput setaf 4)"
+green="${bold}$(tput setaf 2)"
-# Message for an update.
-post_upgrade()
-{
- echo ""
- echo "***************************************************************"
- echo " SDLMAME has been updated. If you are upgrading directly from"
- echo " 0.117 or earlier, you must delete all .cfg files and"
- echo " re-configure your controllers. You should also run"
- echo " 'sdlmame --newini' to force the script to create a new ini"
- echo " file with default settings at ~/.mame/mame.ini"
- echo " since there may be new ini options."
- echo "***************************************************************"
- echo ""
-}
+post_upgrade() {
+ printf "${yellow}==>${all_off} ${bold}ATENTION:${all_off}
+${green}==>${all_off} ${bold}SDLMAME has been updated.${all_off}
+ ${blue}->${all_off} If you are upgrading directly from ${bold}0.117${all_off} or ${bold}earlier${all_off},
+ ${bold}you must delete all .cfg files${all_off} and ${bold}re-configure your controllers${all_off}.
+ You should also run:
+ '# ${bold}sdlmame --newini${all_off}'
+
+ to force the script to create a new ini
+ file with default settings at '${bold}~/.mame/mame.ini${all_off}'
+ since there may be new ini options.\n"
+}