summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Michael Mulesa2021-09-06 18:10:44 +1000
committerJohn-Michael Mulesa2021-09-06 18:10:44 +1000
commita25c6b349de7398788a1f5090eab8470c97b7309 (patch)
treead2344ef05d6dce7323b51c419314c3d8eb1e7b6
downloadaur-a25c6b349de7398788a1f5090eab8470c97b7309.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD47
-rw-r--r--flatout2.desktop8
-rw-r--r--flatout2.install3
-rw-r--r--flatout2.sh9
5 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e9557e63737
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = flatout2-wine-gog
+ pkgdesc = FlatOut 2 using WINE with data via GOG
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://www.gog.com/game/flatout_2
+ install = flatout2.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = innoextract
+ makedepends = icoutils
+ source = setup_flatout2_2.1.0.9.exe::gogdownloader://flatout_2/en1installer1
+ source = setup_flatout2_2.1.0.9.bin::gogdownloader://flatout_2/en1installer2
+ source = flatout2.desktop
+ source = flatout2.sh
+ sha256sums = b13e87de2e7386a120cd6dfc194e6e9a6bd522fe51fb8a7ad3faad6ab0475df9
+ sha256sums = 9d488e515d6e529127a695998c92fdbfd6d94f4cb35919776116ff4ab073e683
+ sha256sums = 866f48abcb74e0f3196c0ec5e37a80fc0e5144dc7ac5c40ab941bd685888ff36
+ sha256sums = cfd01677861a1687c89cbf0165d0054342aea4b46b0b15eeffe05ca80e33a20a
+
+pkgname = flatout2-wine-gog
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c43716b690a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: John-Michael Mulesa <jmulesa at gmail dot com>
+
+pkgname=flatout2-wine-gog
+_pkgname=flatout2
+pkgver=1.2
+_pkgver=2.1.0.9
+pkgrel=1
+pkgdesc="FlatOut 2 using WINE with data via GOG"
+arch=('i686' 'x86_64')
+url="https://www.gog.com/game/flatout_2"
+license=('custom')
+makedepends=('innoextract' 'icoutils')
+install=flatout2.install
+source=("setup_${_pkgname}_${_pkgver}.exe::gogdownloader://flatout_2/en1installer1"
+ "setup_${_pkgname}_${_pkgver}.bin::gogdownloader://flatout_2/en1installer2"
+ "${_pkgname}.desktop" "${_pkgname}.sh")
+sha256sums=('b13e87de2e7386a120cd6dfc194e6e9a6bd522fe51fb8a7ad3faad6ab0475df9'
+ '9d488e515d6e529127a695998c92fdbfd6d94f4cb35919776116ff4ab073e683'
+ '866f48abcb74e0f3196c0ec5e37a80fc0e5144dc7ac5c40ab941bd685888ff36'
+ 'cfd01677861a1687c89cbf0165d0054342aea4b46b0b15eeffe05ca80e33a20a')
+
+# If you want to use lgogdownloader add the following to /etc/makepkg.conf
+# DLAGENTS+=('goggogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find gog installer file (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf. See PKGBUILD for example.")
+
+prepare() {
+ innoextract --gog -s "setup_${_pkgname}_${_pkgver}.exe"
+ icotool -x -o . game/goggame-*.ico
+}
+
+package() {
+ mkdir -p $pkgdir/opt/${_pkgname}
+
+ # Install game icon.
+ install -Dm644 "${srcdir}/goggame-1207660523_6_256x256x32.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}-gog.png"
+
+ # Install game data.
+ cp -r $srcdir/game/* $pkgdir/opt/${_pkgname}/
+
+ # Install desktop file.
+ install -D -m 644 $srcdir/${_pkgname}.desktop \
+ $pkgdir/usr/share/applications/${_pkgname}.desktop
+
+ # Install bash startup script.
+ install -D -m 755 $srcdir/${_pkgname}.sh \
+ $pkgdir/usr/bin/${_pkgname}
+}
diff --git a/flatout2.desktop b/flatout2.desktop
new file mode 100644
index 000000000000..28e56ddf2504
--- /dev/null
+++ b/flatout2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=FlatOut 2
+Comment=FlatOut 2 WINE GOG
+Exec=/usr/bin/flatout2
+Icon=flatout2-gog
+Terminal=false
+Type=Application
+Categories=Application;Game;
diff --git a/flatout2.install b/flatout2.install
new file mode 100644
index 000000000000..2aa0d9fe8645
--- /dev/null
+++ b/flatout2.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "On the first run, game startup may take significantly longer while the wine prefix is prepared."
+}
diff --git a/flatout2.sh b/flatout2.sh
new file mode 100644
index 000000000000..915581c0111c
--- /dev/null
+++ b/flatout2.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+export WINEPREFIX="$HOME"/.flatout2/wine
+if [ ! -d "$HOME"/.flatout2 ] ; then
+ mkdir -p "$HOME"/.flatout2/wine
+ wineboot -u
+ winetricks d3dcompiler_47
+fi
+cd /opt/flatout2
+/usr/bin/wine FlatOut2.exe