summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2023-12-20 17:51:22 +0800
committerYour Name2023-12-20 17:51:22 +0800
commita266b6e351d08dc1bbf84a7cb0ceb22f072ffd4d (patch)
tree49adc111b0f94d760eb3cfc53c7aa97e842fd9f6
parent31fe58f50d97cd4a57fb3f934a79bd4abc50fcaa (diff)
downloadaur-a266b6e351d08dc1bbf84a7cb0ceb22f072ffd4d.tar.gz
update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0aa7e97f611b..c9ebf14d1a3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gradio
pkgdesc = Create UIs for your machine learning model in Python in 3 minutes
- pkgver = 4.8.0
+ pkgver = 4.11.0
pkgrel = 1
url = https://github.com/gradio-app/gradio
arch = x86_64
@@ -31,17 +31,12 @@ pkgbase = python-gradio
depends = python-pydub
depends = python-python-multipart
depends = python-yaml
- depends = python-requests
depends = python-semantic-version
depends = python-tomlkit
depends = python-typer
depends = python-typing_extensions
depends = uvicorn
- depends = ipython
- depends = nodejs
- depends = python-transformers
- depends = python-rich
- source = https://files.pythonhosted.org/packages/source/g/gradio/gradio-4.8.0.tar.gz
- sha512sums = 9e300f6c265f99cd32aa764e79ef3b20fa8321e57afbdd239e63585b6a7d80dde7bb06be3f43bd1a478664aa87dc835a86a6b4f3a5763b780b62dbd304166b36
+ source = https://files.pythonhosted.org/packages/source/g/gradio/gradio-4.11.0.tar.gz
+ sha512sums = 29e5ef953263c5c5c7407709c4ded4b357ceb4eb807fa758444438918418db2008897eba2622f3951c01c5bb86c382839f3ce41350e4524951e6f4bda4a3c122
pkgname = python-gradio
diff --git a/PKGBUILD b/PKGBUILD
index 1583b2a17638..2720ac0d0ba3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
pkgname=python-gradio
_module='gradio'
-pkgver=4.8.0
+pkgver=4.11.0
pkgrel=1
pkgdesc='Create UIs for your machine learning model in Python in 3 minutes '
arch=(x86_64)
url='https://github.com/gradio-app/gradio'
license=('custom')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module/-/_}-$pkgver.tar.gz")
-sha512sums=('9e300f6c265f99cd32aa764e79ef3b20fa8321e57afbdd239e63585b6a7d80dde7bb06be3f43bd1a478664aa87dc835a86a6b4f3a5763b780b62dbd304166b36')
-depends=(python python-aiofiles python-altair python-fastapi python-ffmpy python-gradio-client python-httpx python-huggingface-hub python-importlib_resources python-jinja python-markupsafe python-matplotlib python-numpy python-orjson python-packaging python-pandas python-pillow python-pydantic python-pydub python-python-multipart python-yaml python-requests python-semantic-version python-tomlkit python-typer python-typing_extensions uvicorn)
-depends+=(ipython nodejs python-transformers python-rich)
+sha512sums=('29e5ef953263c5c5c7407709c4ded4b357ceb4eb807fa758444438918418db2008897eba2622f3951c01c5bb86c382839f3ce41350e4524951e6f4bda4a3c122')
+depends=(python python-aiofiles python-altair python-fastapi python-ffmpy python-gradio-client python-httpx python-huggingface-hub python-importlib_resources python-jinja python-markupsafe python-matplotlib python-numpy python-orjson python-packaging python-pandas python-pillow python-pydantic python-pydub python-python-multipart python-yaml python-semantic-version python-tomlkit python-typer python-typing_extensions uvicorn)
makedepends=(python-build python-installer python-wheel python-hatch-requirements-txt python-hatch-fancy-pypi-readme)
build() {