summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaskie2018-02-19 00:56:05 +0900
committertaskie2018-02-19 00:56:05 +0900
commita26c94e7aebc1ac7d62ecaf27e6cb9bf78b41614 (patch)
tree8b9e5de1367a6b735af7bc372564e168cb800355
downloadaur-a26c94e7aebc1ac7d62ecaf27e6cb9bf78b41614.tar.gz
initial commit (r1306.baa8057)
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..104320260d42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = satysfi-git
+ pkgdesc = A new typesetting system with a static type system
+ pkgver = r1306.baa8057
+ pkgrel = 1
+ url = https://github.com/gfngfn/SATySFi
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = libx11
+ makedepends = ocaml-findlib
+ makedepends = opam
+ makedepends = rsync
+ makedepends = wget
+ depends = glibc
+ provides = satysfi
+ source = git+https://github.com/gfngfn/SATySFi
+ md5sums = SKIP
+
+pkgname = satysfi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5efb0c48062c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: taskie <t@skie.jp>
+
+pkgname=satysfi-git
+_pkgname=SATySFi
+pkgver=r1306.baa8057
+pkgrel=1
+pkgdesc="A new typesetting system with a static type system"
+arch=('x86_64')
+url="https://github.com/gfngfn/SATySFi"
+license=('LGPL3')
+depends=('glibc')
+optdepends=()
+makedepends=('git' 'libx11' 'ocaml-findlib' 'opam' 'rsync' 'wget')
+provides=("satysfi")
+options=()
+source=("git+https://github.com/gfngfn/${_pkgname}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ git submodule update --init --recursive
+ export OPAMROOT="${srcdir}/.opam"
+ opam init --yes --no-setup
+ eval "$(opam config env)"
+ opam pin add --yes satysfi .
+}
+
+package() {
+ cd "${_pkgname}"
+ export OPAMROOT="${srcdir}/.opam"
+ install -m755 -d "${pkgdir}/usr/bin"
+ install -m755 "${OPAMROOT}/system/bin/satysfi" "${pkgdir}/usr/bin/"
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}