summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstarmatt2021-07-22 21:11:37 +0200
committerstarmatt2021-07-22 21:11:37 +0200
commita2a224ddb22f9ae6f627028b70911867acd93722 (patch)
tree127fc59e61f70df1ddd4af8920fc66ea18cb24b8
downloadaur-a2a224ddb22f9ae6f627028b70911867acd93722.tar.gz
Added initial PKGBUILD for gnome-shell-extension-windowisready_remover; version 1.12
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da5926669539
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gnome-shell-extension-windowisready_remover
+ pkgdesc = GNOME shell extension that removes the annoying "Windows is Ready" notification.
+ pkgver = 1.12
+ pkgrel = 1
+ url = https://github.com/nunofarruca/WindowIsReady_Remover
+ arch = any
+ license = unknown
+ depends = gnome-shell
+ source = https://github.com/nunofarruca/WindowIsReady_Remover/archive/refs/tags/1.12.tar.gz
+ sha256sums = 2d29638425a266f2b4a9aff16a0c7cc8716974dea5206cae933a05763513be46
+
+pkgname = gnome-shell-extension-windowisready_remover
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bb1050f2fb82
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.gz
+*.pkg.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cb482f14719
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Matthieu Borde <starmatt at free dot fr>
+
+pkgname=gnome-shell-extension-windowisready_remover
+_pkgname=WindowIsReady_Remover
+pkgver=1.12
+pkgrel=1
+pkgdesc='GNOME shell extension that removes the annoying "Windows is Ready" notification.'
+arch=(any)
+url='https://github.com/nunofarruca/WindowIsReady_Remover'
+license=('unknown')
+depends=('gnome-shell')
+source=("https://github.com/nunofarruca/WindowIsReady_Remover/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('2d29638425a266f2b4a9aff16a0c7cc8716974dea5206cae933a05763513be46')
+
+package() {
+ _uuid="windowIsReady_Remover@nunofarruca@gmail.com"
+ _destdir="$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+
+ cd "$_pkgname-$pkgver/$_uuid"
+ install --directory "$_destdir/schemas"
+ install --target-directory "$_destdir" --mode 644 metadata.json *.js
+ install --target-directory "$_destdir/schemas" --mode 644 schemas/*
+}