summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-10-06 20:39:42 +0200
committerStefan Husmann2015-10-06 20:39:42 +0200
commita2a41c312de42522d470a9117ee06c281b69e32a (patch)
treefc2198f4057bb5addd61feaafd37052823ae2870
parentd5e88fcb95f057f367497e2f83c91bc8eeaa1c7f (diff)
downloadaur-a2a41c312de42522d470a9117ee06c281b69e32a.tar.gz
correct
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3cdd7167089..935b69a2c6ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = bibstuff
pkgdesc = Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = http://dschwilk.github.io/bibstuff
arch = any
license = MIT
- depends = python2
+ depends = python2-simpleparse
source = bibstuff.zip::https://github.com/dschwilk/bibstuff/archive/master.zip
md5sums = 4d89e8356f99456adae34aeede5af79b
diff --git a/PKGBUILD b/PKGBUILD
index 1fe3f97c2f24..9a20db9278a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,20 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=bibstuff
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references"
url="http://dschwilk.github.io/bibstuff"
arch=('any')
license=('MIT')
-depends=('python2')
+depends=('python2-simpleparse')
source=(bibstuff.zip::https://github.com/dschwilk/bibstuff/archive/master.zip)
md5sums=('4d89e8356f99456adae34aeede5af79b')
+prepare() {
+ cd $srcdir/$pkgname-master
+ find . -name "*.py" -exec sed -i '1s+python+python2+' {} \;
+}
+
package() {
cd $srcdir/$pkgname-master
python2 setup.py install --root=$pkgdir
@@ -24,5 +29,4 @@ package() {
# copying examples directory
install -d $pkgdir/usr/share/doc/$pkgname/examples
cp examples/* $pkgdir/usr/share/doc/$pkgname/examples
- sed -i '1s+python+python2+' $pkgdir/usr/share/doc/bibstuff/examples/jmaker.py
}