summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-07 17:48:04 +0800
committerzxp198210052024-03-07 17:48:04 +0800
commita3107adb334f268e86b0ba1d76295e9655a3ac80 (patch)
treec5ee0a52f2d10fa6a261d8cfc91f3d042802cadb
parent987d3d9fe6d9eda8dcf506bcf8f22f3bc70209ef (diff)
downloadaur-a3107adb334f268e86b0ba1d76295e9655a3ac80.tar.gz
fix errors
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--dbgate.sh3
3 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88e1d0d39694..30b59446298c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = dbgate-bin
pkgdesc = Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application
pkgver = 5.2.7
- pkgrel = 4
+ pkgrel = 5
url = https://dbgate.org/
arch = aarch64
arch = armv7h
arch = x86_64
license = MIT
- makedepends = squashfuse
+ makedepends = fuse2
depends = electron25
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
+ depends = hicolor-icon-theme
provides = dbgate=5.2.7
conflicts = dbgate
source = LICENSE-5.2.7::https://raw.githubusercontent.com/dbgate/dbgate/v5.2.7/LICENSE
source = dbgate.sh
sha256sums = 4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
source_aarch64 = dbgate-5.2.7-aarch64.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_arm64.AppImage
sha256sums_aarch64 = c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22
source_armv7h = dbgate-5.2.7-armv7h.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 5c96ffd8f592..5edc00040104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dbgate-bin
pkgver=5.2.7
_electronversion=25
-pkgrel=4
+pkgrel=5
pkgdesc="Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application"
arch=(
'aarch64'
@@ -17,12 +17,10 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
+ 'hicolor-icon-theme'
)
makedepends=(
- 'squashfuse'
+ 'fuse2'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_arm64.AppImage")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_armv7l.AppImage")
@@ -32,7 +30,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
sha256sums_aarch64=('c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22')
sha256sums_armv7h=('cc0c7b59475a254bda665b835dcf7f145813f2daa5687dc41e2116b13195fd04')
sha256sums_x86_64=('75801a25bcd13b1f1073f2c8c048f49c7ebe58eb1162f5105b486a0ce99a8696')
diff --git a/dbgate.sh b/dbgate.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/dbgate.sh
+++ b/dbgate.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then