summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2019-07-01 12:34:22 -0700
committerRich Li2019-07-01 12:34:22 -0700
commita32e3b0a48d2622644da37db150d0c5f04aa21fb (patch)
treeb13d6d2b7c5e1aa741c3980445594f1ca9dbda0c
parentf96ae6455a72f06f2c6a34817f454db672932da3 (diff)
downloadaur-a32e3b0a48d2622644da37db150d0c5f04aa21fb.tar.gz
Add optional dependency for rasterio
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c00f79bfaa3..4e658a2ffbef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = python-xarray
optdepends = python-bottleneck: Faster NaN operations
optdepends = python-scipy: OPeNDAP support
optdepends = python-matplotlib: Plotting support
+ optdepends = python-rasterio: Read GeoTiffs and other gridded raster datasets
optdepends = python-dask: Enable out-of-core parallel computation
replaces = python-xray
source = https://files.pythonhosted.org/packages/source/x/xarray/xarray-0.12.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index b5adecd62063..e5d024f4b074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,9 @@ makedepends=('python-setuptools')
depends=('python-numpy' 'python-pandas')
optdepends=('python-netcdf4: NetCDF4 support'
'python-bottleneck: Faster NaN operations'
- # 'python-pynio: GRIB and other file format support' # (no Python 3 support yet)
'python-scipy: OPeNDAP support'
'python-matplotlib: Plotting support'
+ 'python-rasterio: Read GeoTiffs and other gridded raster datasets'
'python-dask: Enable out-of-core parallel computation')
checkdepends=('python-pytest')
replaces=('python-xray')