summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-02-12 20:03:28 +0100
committerbionade242020-02-12 20:03:28 +0100
commita336324142962f3040beba3d8000ce03b1682f24 (patch)
treee21b54b0bf09c004bc4ee297b6675b9a979985cf
parent80aae0a68bfd46164c9b35e49addf093e26a1c1a (diff)
downloadaur-a336324142962f3040beba3d8000ce03b1682f24.tar.gz
Added ROS vars to clear-ros-env.sh
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xclear-ros-env.sh25
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c632cc7ea0a7..ed6c9bedefce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-build-tools-py3
pkgdesc = Utilities for building Arch packages for ROS stacks.
pkgver = 0.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ros-melodic-arch/ros-build-tools-py3
arch = any
license = BSD
@@ -17,7 +17,7 @@ pkgbase = ros-build-tools-py3
source = clear-ros-env.sh
source = create_pkgbuild.py
sha256sums = 5528486d640d91136276edda2075aefc06f360e6297e556051bae57b9479aeda
- sha256sums = e71cdd2288bf3a659fa40824464e64031d2ec45fab57f120d8c49b92954d5ad5
+ sha256sums = 9626b8e5f3865f5640660f4a7f6a00afc4db8448b95329b4d5a64bd691677a88
sha256sums = 6171500f4e807e170f3705277032107b3902502a7fcccf8ab5b300a35580ebf7
pkgname = ros-build-tools-py3
diff --git a/PKGBUILD b/PKGBUILD
index 81af1b5ca997..84e1a383410b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url="https://github.com/ros-melodic-arch/ros-build-tools-py3"
pkgname='ros-build-tools-py3'
pkgver='0.3.1'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
makedepends=()
optdepends=('python3' 'python-argparse' 'python-yaml' 'python-termcolor' 'python-certifi')
@@ -21,7 +21,7 @@ source=('fix-python-scripts.sh'
'create_pkgbuild.py')
sha256sums=('5528486d640d91136276edda2075aefc06f360e6297e556051bae57b9479aeda'
- 'e71cdd2288bf3a659fa40824464e64031d2ec45fab57f120d8c49b92954d5ad5'
+ '9626b8e5f3865f5640660f4a7f6a00afc4db8448b95329b4d5a64bd691677a88'
'6171500f4e807e170f3705277032107b3902502a7fcccf8ab5b300a35580ebf7')
build() {
return 0
diff --git a/clear-ros-env.sh b/clear-ros-env.sh
index efba44a71f30..00655c40da3b 100755
--- a/clear-ros-env.sh
+++ b/clear-ros-env.sh
@@ -1,7 +1,28 @@
#!/bin/bash
+# See https://wiki.ros.org/ROS/EnvironmentVariables
+# Required ROS environment variables
+unset ROS_ROOT
+
+# Additional PATH Environment Variables
+unset ROS_PACKAGE_PATH
+
+# Additional Bash Environment Variables
+unset ROS_LOCATIONS
+unset ROS_WORKSPACE
+
+# Build System Environment Variables
+unset ROS_BOOST_ROOT
+unset ROS_BINDEPS_PATH
+unset ROS_LANG_DISABLE
+unset ROS_OS_OVERRIDE
+
+# See https://wiki.ros.org/ros_environment
unset ROS_DISTRO
-unset ROS_PACKAGE
unset ROS_ETC_DIR
-unset ROS_ROOT
+unset ROS_VERSION
+unset ROS_PYTHON_VERSION
+
+# Taken from old clear-ros-env.sh
+unset ROS_PACKAGE
unset ROS_MASTER