summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2018-12-16 14:13:39 +0100
committerMartin T. H. Sandsmark2018-12-16 14:13:39 +0100
commita34d7c50d77850baeffd4441214ef0898314223f (patch)
tree21634f2a0530e327bceca18e6e45beeacd1ba231
downloadaur-a34d7c50d77850baeffd4441214ef0898314223f.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09506e7cffa0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kuiserver-standalone-git
+ pkgdesc = Standalone version of the KIO job manager
+ pkgver = r72.30f67de
+ pkgrel = 1
+ url = https://github.com/sandsmark/kuiserver-standalone
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ depends = kinit
+ depends = kio
+ depends = kdbusaddons
+ depends = ki18n
+ provides = kuiserver-standalone
+ conflicts = kuiserver-standalone
+ conflicts = plasma-workspace
+ source = git+https://github.com/sandsmark/kuiserver-standalone.git
+ md5sums = SKIP
+
+pkgname = kuiserver-standalone-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83648942b23c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=kuiserver-standalone-git
+pkgver=r72.30f67de
+pkgrel=1
+pkgdesc="Standalone version of the KIO job manager"
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/kuiserver-standalone"
+license=(LGPL)
+depends=(kinit kio kdbusaddons ki18n)
+makedepends=(extra-cmake-modules git)
+provides=(kuiserver-standalone)
+conflicts=(kuiserver-standalone plasma-workspace)
+source=('git+https://github.com/sandsmark/kuiserver-standalone.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd kuiserver-standalone
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kuiserver-standalone \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}