summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiels Abspoel2015-06-08 21:36:58 +0200
committerNiels Abspoel2015-06-08 21:36:58 +0200
commita35faf95679498286223bdca914e4796a8d4eaf0 (patch)
treece1ea938227bcc54f564bba97dd890f78d4b23bd
downloadaur-a35faf95679498286223bdca914e4796a8d4eaf0.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..587d5f23db70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-pg
+ pkgdesc = Pg is the Ruby interface to the Postgresql RDBMS
+ pkgver = 0.18.1
+ pkgrel = 1
+ url = https://bitbucket.org/ged/ruby-pg
+ arch = any
+ license = GPL
+ makedepends = rubygems
+ makedepends = postgresql-libs
+ depends = ruby
+ noextract = pg-0.18.1.gem
+ options = !emptydirs
+ source = http://rubygems.org/downloads/pg-0.18.1.gem
+ md5sums = bc21aeb047b159ef68de2a84061e7f80
+
+pkgname = ruby-pg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1561e82616a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*/
+*~
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85fb2c3896e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Niels Abspoel <aboe76 (at) Gmail.com>
+
+_gemname=pg
+pkgname=ruby-pg
+pkgver=0.18.1
+pkgrel=1
+pkgdesc="Pg is the Ruby interface to the Postgresql RDBMS"
+arch=("any")
+url="https://bitbucket.org/ged/ruby-pg"
+license=("GPL")
+depends=("ruby")
+makedepends=("rubygems" "postgresql-libs")
+conflicts=("")
+options=(!emptydirs)
+source=(http://rubygems.org/downloads/${_gemname}-${pkgver}.gem)
+md5sums=('bc21aeb047b159ef68de2a84061e7f80')
+noextract=(${_gemname}-${pkgver}.gem)
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" \
+ -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+
+}