summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-06-19 12:17:30 +0800
committerChocobo12017-06-19 12:27:43 +0800
commita38ca37d3f3153c101aee23634fb8f2fe9a4bfdd (patch)
tree056eab3cf04dce7b637b06ecc34b6bce1b3eea16
downloadaur-a38ca37d3f3153c101aee23634fb8f2fe9a4bfdd.tar.gz
newpkg: lizard-git 1.0.r3.g6a1ed71-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1793305c7ae4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lizard-git
+ pkgdesc = An efficient compressor with very fast decompression
+ pkgver = 1.0.r3.g6a1ed71
+ pkgrel = 1
+ url = https://github.com/inikep/lizard
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = BSD
+ makedepends = git
+ depends = glibc
+ provides = lizard
+ conflicts = lizard
+ source = git+https://github.com/inikep/lizard.git
+ sha256sums = SKIP
+
+pkgname = lizard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40e02b7cf199
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=lizard-git
+pkgver=1.0.r3.g6a1ed71
+pkgrel=1
+pkgdesc="An efficient compressor with very fast decompression"
+arch=('i686' 'x86_64')
+url="https://github.com/inikep/lizard"
+license=('GPL2' 'BSD')
+depends=('glibc')
+makedepends=('git')
+provides=('lizard')
+conflicts=('lizard')
+source=("git+https://github.com/inikep/lizard.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "lizard"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "lizard"
+
+ make
+}
+
+check() {
+ cd "lizard"
+
+ #make test
+}
+
+package() {
+ cd "lizard"
+
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ install -Dm644 "lib/LICENSE" "$pkgdir/usr/share/licenses/lizard/LICENSE"
+}