summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2022-06-14 18:46:19 -0600
committerBrian Bidulock2022-06-14 18:46:19 -0600
commita39ab559084308ba74f3e49f5a17b1c3477a467f (patch)
tree8da73e8b8c15c366422733ebb39a6f5f37d3dc70
parentaa52e39471e4ebfe1976f34f84a994e2e02731ef (diff)
downloadaur-a39ab559084308ba74f3e49f5a17b1c3477a467f.tar.gz
version 3.2.8b
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
-rw-r--r--xfig.patch51
3 files changed, 61 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f08fde7090b..ad469b51e86f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfig
pkgdesc = An interactive drawing tool
- pkgver = 3.2.8
+ pkgver = 3.2.8b
pkgrel = 1
url = http://mcj.sourceforge.net/
arch = x86_64
@@ -18,14 +18,11 @@ pkgbase = xfig
optdepends = fig2dev: to use the frontend to convert fig files
options = !makeflags
options = !emptydirs
- source = http://downloads.sourceforge.net/mcj/xfig-3.2.8.tar.xz
- source = xfig-aspell.patch
- source = xfig-3.2.5-color-resources.patch
+ source = http://downloads.sourceforge.net/mcj/xfig-3.2.8b.tar.xz
+ source = xfig.patch
source = LICENSE
- sha1sums = 93229765f9e764f76e10585309a6c690554cec64
- sha1sums = a57fcc3c8396d58b19061f9cdd93beea728e38e5
- sha1sums = dd41e0a007bb74b74e1af50b6b04aa6aec61ab22
+ sha1sums = 8cbec8fdbcbdb69a2d50b2adff16e1ea1431fc0a
+ sha1sums = 683ec9bb1b6e40a8e13b3c2da037bb5fb5f8fcd5
sha1sums = 31edf4cfab708820ea3f114d095dfef5aa88e5aa
pkgname = xfig
-
diff --git a/PKGBUILD b/PKGBUILD
index 6d37a6a1bec4..364aa5bb341a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contirbutor: Eric BĂ©langer <eric@archlinux.org>
pkgname=xfig
-pkgver=3.2.8
+pkgver=3.2.8b
pkgrel=1
pkgdesc="An interactive drawing tool"
arch=('x86_64' 'i686')
@@ -13,17 +13,14 @@ optdepends=('fig2dev: to use the frontend to convert fig files')
makedepends=('fig2dev' 'libxaw')
options=('!makeflags' '!emptydirs')
source=(http://downloads.sourceforge.net/mcj/${pkgname}-${pkgver}.tar.xz
- xfig-aspell.patch xfig-3.2.5-color-resources.patch
- LICENSE)
-sha1sums=('93229765f9e764f76e10585309a6c690554cec64'
- 'a57fcc3c8396d58b19061f9cdd93beea728e38e5'
- 'dd41e0a007bb74b74e1af50b6b04aa6aec61ab22'
+ xfig.patch LICENSE)
+sha1sums=('8cbec8fdbcbdb69a2d50b2adff16e1ea1431fc0a'
+ '683ec9bb1b6e40a8e13b3c2da037bb5fb5f8fcd5'
'31edf4cfab708820ea3f114d095dfef5aa88e5aa')
prepare() {
cd ${pkgname}-${pkgver}
- patch -p1 -i "${srcdir}/xfig-aspell.patch"
- patch -p1 -i "${srcdir}/xfig-3.2.5-color-resources.patch"
+ patch -Np2 -i ../xfig.patch
}
build() {
diff --git a/xfig.patch b/xfig.patch
new file mode 100644
index 000000000000..110ebb1359b8
--- /dev/null
+++ b/xfig.patch
@@ -0,0 +1,51 @@
+diff -up src/xfig-3.2.8b/app-defaults/Fig-color.bisque.orig src/xfig-3.2.8b/app-defaults/Fig-color.bisque
+--- src/xfig-3.2.8b/app-defaults/Fig-color.bisque.orig 2019-10-29 03:19:05.000000000 -0600
++++ src/xfig-3.2.8b/app-defaults/Fig-color.bisque 2022-06-14 18:41:52.180000000 -0600
+@@ -72,7 +72,7 @@ Fig*mixedEdit.background: navajowhite2
+ Fig*topruler.background: gray95
+ Fig*sideruler.background: gray95
+ Fig*List*background: gray95
+-Fig*Scrollbar.background: gray95
++! Fig*Scrollbar.background: gray95
+
+ Fig*cancel.background: navajowhite1
+ Fig*dismiss.background: navajowhite1
+@@ -92,8 +92,8 @@ Fig*upd_ctrl_form.upd_ctrl_btns*shadowWi
+ Fig*menu_divider.foreground: red
+
+ !##### Shadows
+-Fig*shadowWidth: 2
+-Fig*Label.shadowWidth: 1
++! Fig*shadowWidth: 2
++! Fig*Label.shadowWidth: 1
+ Fig*horizontal.shadowWidth: 2
+ Fig*Scrollbar.shadowWidth: 2
+ ! no shadows for update indicators
+@@ -124,3 +124,15 @@ Fig*color_box*topShadowPixel: gray80
+
+ Fig*toggle*bottomShadowPixel: gray80
+ Fig*toggle*topShadowPixel: gray50
++
++! repare damage done to scrollbar shadows non color resources file
++
++Fig*horizontal.topShadowPixel: gray95
++Fig*horizontal.bottomShadowPixel: gray50
++Fig*horizontal.topShadow: gray95
++Fig*horizontal.bottomShadow: gray50
++
++Fig*Scrollbar.topShadow: gray95
++Fig*Scrollbar.bottomShadow: gray50
++Fig*Scrollbar.topShadowPixel: gray95
++Fig*Scrollbar.bottomShadowPixel: gray50
+diff -up src/xfig-3.2.8b/app-defaults/Fig.in.orig src/xfig-3.2.8b/app-defaults/Fig.in
+--- src/xfig-3.2.8b/app-defaults/Fig.in.orig 2020-08-03 02:22:41.000000000 -0600
++++ src/xfig-3.2.8b/app-defaults/Fig.in 2022-06-14 18:42:22.860000000 -0600
+@@ -34,7 +34,7 @@ Fig.pdfviewer: xdg-open %f
+ ! Spell check program - put your favorite spelling check program here.
+ ! It must write the misspelled words to standard output.
+
+-Fig.spellcheckcommand: spell %f
++Fig.spellcheckcommand: aspell %f
+
+ ! delay before spinner automatically counts when pressed (milliseconds)
+ Fig.spinner_delay: 1000