summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-07-16 15:34:35 +0200
committerbartus2021-07-16 15:34:35 +0200
commita3bda40795c26a5d5cbf5850d616afcd90e30e06 (patch)
tree0ec2cc678bd1001efd23f2280aadebad2d310075
parent00d6b2f8ccb2f75dd4e5de3d355bfd11fec8bbd8 (diff)
downloadaur-a3bda40795c26a5d5cbf5850d616afcd90e30e06.tar.gz
Silent annoying tbb message, and misused gcc flags.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa4d8f4e7e61..8631fb61c444 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -95,10 +95,11 @@ prepare() {
sed "1i\#define AVFMT_RAWPICTURE 0x0020" -i modules/highgui/src/cap_ffmpeg_impl.hpp
sed "1i\#define CODEC_FLAG_GLOBAL_HEADER AV_CODEC_FLAG_GLOBAL_HEADER" -i modules/highgui/src/cap_ffmpeg_impl.hpp
sed "1i\#define AV_CODEC_FLAG_GLOBAL_HEADER (1 << 22)" -i modules/highgui/src/cap_ffmpeg_impl.hpp
+ sed "/prototypes/d" -i cmake/OpenCVCompilerOptions.cmake
}
build() {
- export CXXFLAGS+=" -std=c++14"
+ export CXXFLAGS+=" -std=c++14 -DTBB_SUPPRESS_DEPRECATED_MESSAGES"
cmake -S "$srcdir/$_pkgbase-$pkgver" -B build "${_cmakeopts[@]}"
make -C build
}