summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-08-28 22:23:03 +0800
committerChocobo12021-08-28 22:23:03 +0800
commita3cd3bfa8c7969b1c83a7bea0a89a40e16a99702 (patch)
treec09bf395ab6fccc612cbf3f9642d4d99ca90cd43
parent148652b4d0daf59df4d8917381cc20e52e7063b5 (diff)
downloadaur-a3cd3bfa8c7969b1c83a7bea0a89a40e16a99702.tar.gz
upgpkg: aspell-git 0.60.8.20190921.r37.gcef82a8-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c837819ef951..9ec23f3ce2a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = aspell-git
pkgdesc = Free and Open Source spell checker
- pkgver = 0.60.7.rc1.r3.gb2e2b25
+ pkgver = 0.60.8.20190921.r37.gcef82a8
pkgrel = 1
url = http://aspell.net/
arch = i686
arch = x86_64
license = LGPL
makedepends = git
+ depends = gcc-libs
depends = ncurses
optdepends = perl: to import old dictionaries
provides = aspell
@@ -16,4 +17,3 @@ pkgbase = aspell-git
sha256sums = SKIP
pkgname = aspell-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 95838106fb7e..aaf331937aa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=aspell-git
-pkgver=0.60.7.rc1.r3.gb2e2b25
+pkgver=0.60.8.20190921.r37.gcef82a8
pkgrel=1
pkgdesc="Free and Open Source spell checker"
arch=('i686' 'x86_64')
url="http://aspell.net/"
license=('LGPL')
-depends=('ncurses')
+depends=('gcc-libs' 'ncurses')
makedepends=('git')
optdepends=('perl: to import old dictionaries')
provides=('aspell')
@@ -20,10 +20,10 @@ sha256sums=('SKIP')
pkgver() {
cd "aspell"
- _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/rel-//p}')
- _rev=$(git rev-list --count rel-$_tag..HEAD)
+ _tag=$(git tag -l --sort -v:refname | sed '/rc[0-9]*/d' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/-/./g'
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^rel-//;s/-/./g'
}
build() {
@@ -31,7 +31,8 @@ build() {
PERL_USE_UNSAFE_INC=1 ./autogen
./configure \
- --prefix="/usr" --sysconfdir="/etc" \
+ --prefix="/usr" \
+ --sysconfdir="/etc" \
--enable-static
make
}