summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-05-04 23:41:06 +0200
committerFabioLolix2023-05-04 23:41:06 +0200
commita3cd83906840668eb13ea119efee47a7a04bef0f (patch)
treeb273a547850d9b77ae849373572478f95076ceba
parent4c12b6f9b47330881cd1f4451463c6cbc3fda798 (diff)
downloadaur-a3cd83906840668eb13ea119efee47a7a04bef0f.tar.gz
revision
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD49
2 files changed, 42 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 598dbe9ab0ef..a9c6ef68c535 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = foliate-git
- pkgdesc = A simple and modern GTK eBook reader
- pkgver = 1.5.3.r10.gd35e3e6
- pkgrel = 1
+ pkgdesc = Simple and modern GTK eBook reader
+ pkgver = 2.6.4.r98.g3a9e148
+ pkgrel = 2
url = https://johnfactotum.github.io/foliate/
- arch = i686
- arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
- license = GPL-3.0
- makedepends = meson>=0.40
+ arch = any
+ license = GPL3
+ makedepends = meson
makedepends = ninja
makedepends = git
- depends = gjs>=1.52.0
- depends = webkit2gtk
- depends = gettext
+ depends = gjs
+ depends = gtk4
+ depends = webkitgtk-6.0
optdepends = hyphen: Auto-hyphenation support
optdepends = hyphen-en: Hyphenation rules for English; you may choose package for your language
optdepends = dictd: Offline dictionary support
@@ -22,9 +18,9 @@ pkgbase = foliate-git
optdepends = espeak-ng: Text-to-speech support
provides = foliate
conflicts = foliate
- replaces = foliate
- source = foliate::git+https://github.com/johnfactotum/foliate.git#branch=master
- md5sums = SKIP
+ source = git+https://github.com/johnfactotum/foliate.git#branch=gtk4
+ source = git+https://github.com/johnfactotum/foliate-js.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = foliate-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d8a2b9f8e362..904853d5861d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,47 @@
-# Maintainer: schw0reismus <schw0reismus@protonmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: schw0reismus <schw0reismus@protonmail.com>
pkgname=foliate-git
-pkgver=1.5.3.r10.gd35e3e6
-pkgrel=1
-pkgdesc="A simple and modern GTK eBook reader"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+pkgver=2.6.4.r98.g3a9e148
+pkgrel=2
+pkgdesc="Simple and modern GTK eBook reader"
+arch=(any)
url="https://johnfactotum.github.io/foliate/"
-license=('GPL-3.0')
-depends=('gjs>=1.52.0' 'webkit2gtk' 'gettext')
-makedepends=('meson>=0.40' 'ninja' 'git')
+license=(GPL3)
+depends=(gjs gtk4 webkitgtk-6.0)
+makedepends=(meson ninja git)
optdepends=('hyphen: Auto-hyphenation support'
'hyphen-en: Hyphenation rules for English; you may choose package for your language'
'dictd: Offline dictionary support'
'festival: Text-to-speech support'
'espeak-ng: Text-to-speech support'
)
-source=("${pkgname%-git}::git+https://github.com/johnfactotum/${pkgname%-git}.git#branch=master")
-provides=("${pkgname%-git}")
-replaces=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-md5sums=('SKIP')
+provides=(foliate)
+conflicts=(foliate)
+source=("git+https://github.com/johnfactotum/foliate.git#branch=gtk4"
+ "git+https://github.com/johnfactotum/foliate-js.git")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
- cd "$srcdir"/"${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd foliate
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd foliate
+ git submodule init
+ git config submodule.src/foliate-js.url "${srcdir}/foliate-js"
+ git -c protocol.file.allow=always submodule update
}
build() {
- cd "$srcdir"/"${pkgname%-git}"
- meson build --prefix=/usr
- ninja -C build
+ cd foliate
+ meson build --prefix=/usr
+ ninja -C build
}
package(){
- cd "$srcdir"/"${pkgname%-git}"
- DESTDIR="$pkgdir" ninja -C build install
+ cd foliate
+ DESTDIR="$pkgdir" ninja -C build install
}