summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2017-05-14 16:01:25 +0200
committerBruno Pagani2017-05-14 16:01:25 +0200
commita3cd99a3c0bd63f992e3af13ccf3536865db4ffc (patch)
treecdd66f52a2699ae064a30c25f10cdd7a2f18bf52
parent616c522486dbf2e9dfddb0c9ad6cf893607d6f03 (diff)
downloadaur-a3cd99a3c0bd63f992e3af13ccf3536865db4ffc.tar.gz
upgpkg: certbot-user 0.14.0-1
upstream release
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD24
2 files changed, 28 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f216a494f1f9..6d6c874e1fd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,34 @@
pkgbase = certbot-user
pkgdesc = Let’s Encrypt certbot running as certbot user rather than root, with either standalone or webroot mode.
- pkgver = 0.13.0
+ pkgver = 0.14.0
pkgrel = 1
url = https://certbot.eff.org
arch = any
license = Apache
- checkdepends = python2-nose
+ checkdepends = python-nose
depends = ca-certificates
- depends = python2-acme=0.13.0
- depends = python2-configargparse
- depends = python2-configobj
- depends = python2-cryptography
- depends = python2-pyopenssl
- depends = python2-mock
- depends = python2-parsedatetime
- depends = python2-psutil
- depends = python2-pyrfc3339
- depends = python2-pytz
- depends = python2-requests
- depends = python2-setuptools
- depends = python2-six
- depends = python2-zope-component
- depends = python2-zope-interface
+ depends = python-acme=0.14.0
+ depends = python-configargparse
+ depends = python-configobj
+ depends = python-cryptography
+ depends = python-mock
+ depends = python-parsedatetime
+ depends = python-pyopenssl
+ depends = python-pyrfc3339
+ depends = python-pytz
+ depends = python-setuptools
+ depends = python-six
+ depends = python-zope-component
+ depends = python-zope-interface
depends = systemd
provides = certbot
conflicts = certbot
- source = https://pypi.io/packages/source/c/certbot/certbot-0.13.0.tar.gz
- source = https://pypi.io/packages/source/c/certbot/certbot-0.13.0.tar.gz.asc
+ source = https://pypi.io/packages/source/c/certbot/certbot-0.14.0.tar.gz
+ source = https://pypi.io/packages/source/c/certbot/certbot-0.14.0.tar.gz.asc
source = certbot.tmpfiles
source = certbot.sysusers
validpgpkeys = A2CFB51FA275A7286234E7B24D17C995CD9775F2
- sha256sums = f63ad7747edaca2fb7d60c28882e44d2f48ff1cca9b9c7c251ad47e2189c00f3
+ sha256sums = 98add3721e1edaedb404879a9d39bd49020e94fc8eedbc46032a00ada51d7741
sha256sums = SKIP
sha256sums = ca72fe5f7e6ccbbe8afc084d9255f93e3b81ce2793a77103a9382fa9eaff6c97
sha256sums = 151621a821f56178408851e016c7fda67dc4c726f210ad3279b29fd1f43282fa
diff --git a/PKGBUILD b/PKGBUILD
index 450c121b2e47..ab9665825674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,45 +4,41 @@
_pkgname=certbot
pkgname=${_pkgname}-user
-pkgver=0.13.0
+pkgver=0.14.0
pkgrel=1
pkgdesc="Let’s Encrypt certbot running as certbot user rather than root, with either standalone or webroot mode."
arch=('any')
license=('Apache')
url="https://${_pkgname}.eff.org"
-depends=('ca-certificates' "python2-acme=${pkgver}" 'python2-configargparse' 'python2-configobj'
- 'python2-cryptography' 'python2-pyopenssl' 'python2-mock' 'python2-parsedatetime'
- 'python2-psutil' 'python2-pyrfc3339' 'python2-pytz' 'python2-requests' 'python2-setuptools'
- 'python2-six' 'python2-zope-component' 'python2-zope-interface' 'systemd')
-checkdepends=('python2-nose')
+depends=('ca-certificates' "python-acme=${pkgver}" 'python-configargparse' 'python-configobj'
+ 'python-cryptography' 'python-mock' 'python-parsedatetime' 'python-pyopenssl'
+ 'python-pyrfc3339' 'python-pytz' 'python-setuptools' 'python-six'
+ 'python-zope-component' 'python-zope-interface' 'systemd')
+checkdepends=('python-nose')
conflicts=('certbot')
provides=('certbot')
source=("https://pypi.io/packages/source/c/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"{,.asc}
"${_pkgname}.tmpfiles"
"${_pkgname}.sysusers")
validpgpkeys=('A2CFB51FA275A7286234E7B24D17C995CD9775F2') # Let's Encrypt Client Team <letsencrypt-client@eff.org>
-sha256sums=('f63ad7747edaca2fb7d60c28882e44d2f48ff1cca9b9c7c251ad47e2189c00f3'
+sha256sums=('98add3721e1edaedb404879a9d39bd49020e94fc8eedbc46032a00ada51d7741'
'SKIP'
'ca72fe5f7e6ccbbe8afc084d9255f93e3b81ce2793a77103a9382fa9eaff6c97'
'151621a821f56178408851e016c7fda67dc4c726f210ad3279b29fd1f43282fa')
-prepare() {
- sed -i "/'argparse',/d" ${_pkgname}-${pkgver}/setup.py
-}
-
build() {
cd ${_pkgname}-${pkgver}
- python2 setup.py build
+ python setup.py build
}
check() {
cd ${_pkgname}-${pkgver}
- python2 setup.py test
+ python setup.py test
}
package() {
cd ${_pkgname}-${pkgver}
- python2 setup.py install --root="${pkgdir}" --skip-build --optimize=1
+ python setup.py install --root="${pkgdir}" --skip-build --optimize=1
install -Dm644 "${srcdir}"/${_pkgname}.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/${_pkgname}.conf
install -Dm644 "${srcdir}"/${_pkgname}.sysusers "${pkgdir}"/usr/lib/sysusers.d/${_pkgname}.conf