summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-17 09:11:57 +0100
committerCarl Smedstad2024-01-17 09:17:34 +0100
commita3e34ad5594e7993c6b09609e58c12286c6d8155 (patch)
tree19c4700d3da168d331dd47e7307384a1be809b79
parent0988c71aadc63cf5a4477feea64738287b29e5d1 (diff)
downloadaur-a3e34ad5594e7993c6b09609e58c12286c6d8155.tar.gz
upgpkg: 2.5.0-3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b13c008b0a17..30ae768a05e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,15 @@
pkgbase = rpmlint
pkgdesc = A tool for checking common errors in rpm packages
pkgver = 2.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/rpm-software-management/rpmlint
arch = any
- license = GPL2
+ license = GPL-2.0-only
+ checkdepends = appstream-glib
+ checkdepends = checkbashisms
+ checkdepends = dash
+ checkdepends = desktop-file-utils
+ checkdepends = python-pyenchant
checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index 42013fc611bd..3bb101724fbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
pkgname=rpmlint
pkgver=2.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="A tool for checking common errors in rpm packages"
arch=(any)
url="https://github.com/rpm-software-management/rpmlint"
-license=(GPL2)
+license=(GPL-2.0-only)
depends=(
binutils
cpio
@@ -29,7 +29,14 @@ makedepends=(
python-setuptools
python-wheel
)
-checkdepends=(python-pytest)
+checkdepends=(
+ appstream-glib
+ checkbashisms
+ dash
+ desktop-file-utils
+ python-pyenchant
+ python-pytest
+)
optdepends=(
'appstream-glib: for AppData file validation'
'checkbashisms: for checking bashisms'
@@ -52,7 +59,7 @@ build() {
check() {
cd "$_archive"
- script --command 'pytest --override-ini="addopts="'
+ script --return --command 'pytest --override-ini="addopts="'
}
package() {