summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtto Sabart2015-06-30 09:55:30 +0000
committerOtto Sabart2015-06-30 09:55:30 +0000
commita40e484b5b17b6584d132377f7a0bf59ae03d728 (patch)
treed82ed2c14924c78ef2e932d5e4439a55d8c174ea
downloadaur-a40e484b5b17b6584d132377f7a0bf59ae03d728.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD29
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42753aedbca2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vlna
+ pkgdesc = TeX and LaTeX utility to add the ~ by Czech typesetting conventions
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://petr.olsak.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ conflicts = texlive-bin
+ source = ftp://math.feld.cvut.cz/pub/olsak/vlna/vlna-1.5.tar.gz
+ source = LICENSE
+ md5sums = 82f975d59692e159794cc6a717e0f75d
+ md5sums = 51eec77b6812a9b6c0c0d6cb0bf3ced6
+
+pkgname = vlna
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..63e5353718e7
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+Šíření programu:
+----------------
+
+Program poskytuji k veřejnému použití. Pokud někdo udělá užitečné
+změny ve zdrojovém textu CWEB, chtěl bych být o tom informován. Bez
+souhlasu autora nemůže být změněný program šířen pod stejným názvem.
+
+Nedávám žádnou záruku, že program nepoškodí mnohahodinovou práci,
+kterou uživatelé editovali. Program sice vytváří zálohové soubory, ale
+ty se při dalším použití programu mažou.
+
+Program distribution:
+---------------------
+
+The program may be freely used. If somebody makes useful changes
+in the CWEB source code, I want to be informed about it. The
+modified version must not be distributed under the same name
+without author's consent.
+
+The author gives no warranty that the program will not damage your
+file that you have been editing for many hours. Although the program
+creates backup files, these files are deleted after subsequent use
+of the program.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3a1463066e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=vlna
+pkgver=1.5
+pkgrel=1
+pkgdesc="TeX and LaTeX utility to add the ~ by Czech typesetting conventions"
+arch=('i686' 'x86_64')
+url="http://petr.olsak.net/"
+license=('custom')
+depends=('glibc')
+conflicts=('texlive-bin')
+source=(ftp://math.feld.cvut.cz/pub/olsak/vlna/vlna-$pkgver.tar.gz \
+ LICENSE)
+md5sums=('82f975d59692e159794cc6a717e0f75d'
+ '51eec77b6812a9b6c0c0d6cb0bf3ced6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ install -D -m644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: