summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Bernardoff2015-06-27 09:51:43 +0200
committerVincent Bernardoff2015-06-27 09:51:43 +0200
commita41ad4611e7c875b86f97fa5a35a00f01343f597 (patch)
tree5f8c86dfeba0deeef9663152a9ff3a7edae16e8f
downloadaur-a41ad4611e7c875b86f97fa5a35a00f01343f597.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
-rw-r--r--quarry.cfg6
-rw-r--r--quarry.install8
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d750104f157
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = quarry-git
+ pkgdesc = Quarry is a multi-purpose GUI for several board games, at present Go, Amazons and Othello.
+ pkgver = 20120330
+ pkgrel = 1
+ url = http://gitorious.org/quarry
+ install = quarry.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = xmlto
+ depends = librsvg>=2.5
+ source = quarry.cfg
+ sha1sums = 9d6d07f955f642f7feb69b90c971da9229eb1e2c
+
+pkgname = quarry-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b97f2ec3fc2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Vincent Bernardoff <vbmithr@gmail.com>
+
+pkgname=quarry-git
+pkgver=20120330
+pkgrel=1
+pkgdesc="Quarry is a multi-purpose GUI for several board games, at present Go, Amazons and Othello."
+url="http://gitorious.org/quarry"
+depends=('librsvg>=2.5')
+makedepends=('xmlto')
+source=('quarry.cfg')
+sha1sums=('9d6d07f955f642f7feb69b90c971da9229eb1e2c')
+install="quarry.install"
+arch=('i686' 'x86_64')
+license=('GPL')
+
+_gitroot="git://gitorious.org/quarry/quarry.git"
+_gitname="quarry"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ ./configure --prefix=/usr --disable-scrollkeeper-update
+ make
+ make html
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ make DESTDIR=$startdir/pkg install
+ cp ../../quarry.cfg $startdir/pkg/usr/share/quarry
+}
diff --git a/quarry.cfg b/quarry.cfg
new file mode 100644
index 000000000000..21d6f6c04f1f
--- /dev/null
+++ b/quarry.cfg
@@ -0,0 +1,6 @@
+[GTP Engine "GNU Go"]
+Screen name format = "%n %v"
+Name = "GNU Go"
+Version = ""
+Command line = "/usr/bin/gnugo --mode gtp --quiet"
+Supported games = "Go" \ No newline at end of file
diff --git a/quarry.install b/quarry.install
new file mode 100644
index 000000000000..ae82ee5e12eb
--- /dev/null
+++ b/quarry.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo '===> NOTICE:
+ To play against the computer, you will need to install additional software.
+ E.g. to play go, install the gnugo package from extra and add the engine to
+ quarry using the preferences dialog (gnugo --mode gtp --quiet). See
+ http://download.gna.org/quarry/help/en/quarry.html for more information on
+ this subject.'
+}