summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Hornich2020-09-16 15:59:19 +0200
committerJulian Hornich2020-09-16 15:59:19 +0200
commita41af752a47a05e9bdb81c8406840b9ef3ada0a1 (patch)
tree5f9da5836e47dd794dd8d81033404b3b06f0f279
parent45ff0668464fb30354caf9870ebce10370e0aba2 (diff)
downloadaur-a41af752a47a05e9bdb81c8406840b9ef3ada0a1.tar.gz
update to version 0.9.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0496c178f0ba..2cfd3e55d9f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolfin-hpc
pkgdesc = DOLFIN HPC is a special branch of DOLFIN optimized for distributed memory architectures
- pkgver = 0.9.1_hpc_20200720
+ pkgver = 0.9.2_hpc_20200914
pkgrel = 1
url = https://bitbucket.org/adaptivesimulations/dolfin-hpc/
arch = i686
@@ -21,7 +21,7 @@ pkgbase = dolfin-hpc
provides = dolfin
conflicts = dolfin
options = !emptydirs
- source = dolfin-hpc::git+https://bitbucket.org/adaptivesimulations/dolfin-hpc.git#tag=0.9.1-hpc
+ source = dolfin-hpc::git+https://bitbucket.org/adaptivesimulations/dolfin-hpc.git#tag=0.9.2-hpc
md5sums = SKIP
pkgname = dolfin-hpc
diff --git a/PKGBUILD b/PKGBUILD
index 2f67c66dc2e4..fb06b2b292be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Julian Hornich <hornich at kth dot se>
pkgname=dolfin-hpc
-pkgver=0.9.1_hpc_20200720
+pkgver=0.9.2_hpc_20200914
pkgrel=1
pkgdesc="DOLFIN HPC is a special branch of DOLFIN optimized for distributed memory architectures"
-_tag=0.9.1-hpc
+_tag=0.9.2-hpc
arch=('i686' 'x86_64')
url="https://bitbucket.org/adaptivesimulations/dolfin-hpc/"
license=('LGPL')
@@ -22,13 +22,15 @@ pkgver() {
echo "${_tag}_$(git log --format="%cd" --date=short -1 | sed 's/-//g')" | sed 's/-/_/g'
}
+_petsc_dir=/opt/petsc/linux-c-opt
+
prepare() {
cd dolfin-hpc
sh regen.sh
- ./configure --prefix=${pkgdir}/opt/dolfin PYTHON=python3 CXXFLAGS="-O3 -march=native -std=c++14" \
- --with-petsc=/opt/petsc/linux-c-opt --with-gts --enable-python --with-parmetis \
- --enable-quadrature --enable-mpi --enable-mpi-io --with-phmap --enable-function-cache \
- --enable-optimize-p1 --enable-opt-basis
+ ./configure --prefix=${pkgdir}/opt/${pkgname} PYTHON=python3 CXXFLAGS="-O3 -march=native" \
+ --with-petsc=${_petsc_dir} --with-gts --enable-python --with-parmetis \
+ --enable-quadrature --enable-mpi --enable-mpi-io --with-phmap --enable-function-cache \
+ --enable-optimize-p1 --enable-opt-basis --with-convert
}
build() {