summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevninja2016-04-10 21:02:15 -0400
committerdevninja2016-04-10 21:02:15 -0400
commita4210ba61f0daa17157fe2eb113def0180364800 (patch)
tree4ce102e9dd65e621a63774a662c68f542229d65c
downloadaur-a4210ba61f0daa17157fe2eb113def0180364800.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdc5a7dfc040
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Apr 11 01:01:59 UTC 2016
+pkgbase = i2p-plugin-seedless
+ pkgdesc = A distributed email client for I2P
+ pkgver = 0.1.7_0.1.12
+ pkgrel = 1
+ url = http://sponge.i2p/files/seedless/doc/how-it-works.txt
+ arch = any
+ groups = i2p-plugins
+ license = GPLv3
+ makedepends = unzip
+ depends = i2p
+ depends = i2p-neodatis
+ provides = i2p-seedless
+ noextract = file://02_seedless.xpi2p
+ source = file://02_seedless.xpi2p
+ sha256sums = 26df04b135a9b0a4fcd37e8f911972c157529b84c51a7569695da2e6ce366989
+
+pkgname = i2p-plugin-seedless
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b61dedf0b0ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: GI Jack <iamjacksemail@hackermail.com>
+
+# This is a packaged plugin for i2p. It assumes you are using the packaging of
+# i2p as used with the arch i2p package in AUR. This package is to keep all
+# software maintained by the system package manager, and to facilitate
+# redistribution of botes as an arch package
+
+_pluginame=seedless
+pkgname=i2p-plugin-${_pluginame}
+pkgver=0.1.7_0.1.12
+pkgrel=1
+pkgdesc="A distributed email client for I2P"
+arch=('any')
+url="http://sponge.i2p/files/seedless/doc/how-it-works.txt"
+license=('GPLv3')
+groups=('i2p-plugins')
+depends=('i2p' 'i2p-neodatis')
+makedepends=('unzip')
+provides=('i2p-seedless')
+# get this from http://sponge.i2p/files/seedless/02_seedless.xpi2p
+source=("file://02_${_pluginame}.xpi2p")
+noextract=("file://02_${_pluginame}.xpi2p")
+sha256sums=('26df04b135a9b0a4fcd37e8f911972c157529b84c51a7569695da2e6ce366989')
+
+prepare() {
+ cd "${srcdir}"
+
+ #yeah, this is a regular zip file, but with some wierd shit added as a header.
+ # nooo, they couldn't just use an index file like normal people.
+ local -i headlength=56
+
+ local outfile="${_pluginame}.zip"
+ local infile="02_${_pluginame}.xpi2p"
+ dd if="${infile}" bs=${headlength} skip=1 of="${outfile}"
+ unzip -d i2p "$outfile"
+}
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/opt/i2p/.i2p/plugins/"
+ cp -Ra "i2p" "${pkgdir}/opt/i2p/.i2p/plugins/02_${_pluginame}"
+}
+