summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArsen Musayelyan2021-01-08 19:04:26 -0800
committerArsen Musayelyan2021-01-08 19:04:26 -0800
commita432a37c6c683bdd9577cd968814c5799dbcbf13 (patch)
tree794f3d7d3882f457dbfe27a24af9b4e9c5ae6823
parentd43028884fe7eac664f43eabb3964f3965518aa8 (diff)
downloadaur-a432a37c6c683bdd9577cd968814c5799dbcbf13.tar.gz
Update to go version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fde58ffd8cfc..49ad8d6cb308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,12 @@
pkgbase = opensend-git
- pkgdesc = Send files and URLs securely across systems
- pkgver = r38.003c27d
+ pkgdesc = Send files and securely across systems
+ pkgver = r39.07e35af
pkgrel = 1
arch = any
- license = GPLv2
- depends = python
- depends = python-pip
- depends = python-pynacl
- depends = python-zeroconf
- depends = python-pyftpdlib
- depends = python-pyqt5
- depends = avahi
- source = git+https://gitlab.com/moussaelianarsen/opensend.git
+ license = Apache-2.0
+ makedepends = go
+ backup = etc/opensend.toml
+ source = git+https://gitea.arsenm.dev/opensend/opensend.git
md5sums = SKIP
pkgname = opensend-git
diff --git a/PKGBUILD b/PKGBUILD
index eca81c1b2b66..6d490bbad306 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Arsen Musayelyan <moussaelianarsen@gmail.com>
pkgname=opensend-git
-pkgver=r38.003c27d
+pkgver=r39.07e35af
pkgrel=1
-pkgdesc="Send files and URLs securely across systems"
+pkgdesc="Send files and securely across systems"
arch=('any')
-license=('GPLv2')
-depends=('python' 'python-pip' 'python-pynacl' 'python-zeroconf' 'python-pyftpdlib' 'python-pyqt5' 'avahi')
-source=('git+https://gitlab.com/moussaelianarsen/opensend.git')
+license=('Apache-2.0')
+makedepends=('go')
+source=('git+https://gitea.arsenm.dev/opensend/opensend.git')
md5sums=('SKIP')
+backup=('etc/opensend.toml')
pkgver() {
- cd "$srcdir/opensend"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/opensend"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/opensend"
+ make
+}
package() {
cd "$srcdir/opensend"
- DESTDIR="$pkgdir/" SUPRESSPIP=true python3 install.py
- # Install PyAESCrypt using pip as it is not available in repos or AUR
- python3 -m pip install pyAesCrypt
+ make DESTDIR="$pkgdir" install
}