summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomZ2017-08-03 13:24:38 +0200
committerTomZ2017-08-03 13:24:38 +0200
commita442889efa8745f55640002f0ebbb6550f8cbf11 (patch)
treefc6ca3a78aea5d185127a40877d7c479c66c4e68
parent302a07dc2836d3ece70253f7e184575d67ae6e77 (diff)
downloadaur-a442889efa8745f55640002f0ebbb6550f8cbf11.tar.gz
Upgrade to 1.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--patch13161
3 files changed, 7 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4740e9aa95f9..70884e6b4973 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 25 09:29:06 UTC 2017
+# Thu Aug 3 11:24:27 UTC 2017
pkgbase = bitcoin-classic-daemon
pkgdesc = Bitcoin Classic with bitcoind, bitcoin-tx, and bitcoin-cli
- pkgver = 1.2.5
+ pkgver = 1.3.2
pkgrel = 1
url = https://bitcoinclassic.com/
install = bitcoin.install
@@ -22,10 +22,10 @@ pkgbase = bitcoin-classic-daemon
conflicts = bitcoin-cli
conflicts = bitcoin-tx
backup = etc/bitcoin/bitcoin.conf
- source = bitcoin-classic-daemon-1.2.5.tar.gz::https://github.com/bitcoinclassic/bitcoinclassic/archive/v1.2.5.tar.gz
+ source = bitcoin-classic-daemon-1.3.2.tar.gz::https://github.com/bitcoinclassic/bitcoinclassic/archive/v1.3.2.tar.gz
source = bitcoin.logrotate
source = bitcoin.conf
- sha256sums = 900218eb2cd40c96a357a601e17fc6eacc91970f369761462de5a695c20701d5
+ sha256sums = 2a709967fcdb1d9f09c0a083c14029891360e22f6b82813b89b39cc4eff6ce77
sha256sums = 7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73
sha256sums = c8787560c6423605796c8d3e080cb522ed849cea12b5c23293c22e405a015a53
diff --git a/PKGBUILD b/PKGBUILD
index c2da62b45162..8b4d23c64185 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Tom Zander
pkgname=bitcoin-classic-daemon
-pkgver=1.2.5
+pkgver=1.3.2
pkgrel=1
pkgdesc='Bitcoin Classic with bitcoind, bitcoin-tx, and bitcoin-cli'
arch=('i686' 'x86_64')
url="https://bitcoinclassic.com/"
license=('MIT')
-depends=('boost-libs' 'libevent' 'openssl-1.0' 'miniupnpc' 'zeromq')
+depends=('boost-libs' 'libevent' 'openssl' 'miniupnpc' 'zeromq')
makedepends=('boost')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-tx')
conflicts=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-tx')
@@ -16,15 +16,12 @@ backup=("etc/bitcoin/bitcoin.conf")
source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/bitcoinclassic/bitcoinclassic/archive/v${pkgver}.tar.gz"
"bitcoin.logrotate"
"bitcoin.conf")
-sha256sums=('900218eb2cd40c96a357a601e17fc6eacc91970f369761462de5a695c20701d5'
+sha256sums=('2a709967fcdb1d9f09c0a083c14029891360e22f6b82813b89b39cc4eff6ce77'
"7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73"
"c8787560c6423605796c8d3e080cb522ed849cea12b5c23293c22e405a015a53")
build() {
cd "bitcoinclassic-$pkgver"
- export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
- export CXXFLAGS+=" -I/usr/include/openssl-1.0"
- export LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl"
./autogen.sh
./configure --prefix=/usr --with-incompatible-bdb --with-gui=no --enable-hardening \
--enable-reduce-exports --disable-gui-tests --disable-maintainer-mode
diff --git a/patch131 b/patch131
deleted file mode 100644
index 21067db0b11c..000000000000
--- a/patch131
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/src/Logger.cpp b/src/Logger.cpp
-index 3083b2ee1..801ca0681 100644
---- a/src/Logger.cpp
-+++ b/src/Logger.cpp
-@@ -122,7 +122,9 @@ short Log::Manager::section(const char *category)
- return Log::Global;
- auto iter = d->categoryMapping.find(category);
- assert (iter != d->categoryMapping.end());
-- return iter->second;
-+ if (iter == d->categoryMapping.end())
-+ return iter->second;
-+ return Log::Global;
- }
-
- Log::Manager *Log::Manager::instance()
-diff --git a/src/addrman.cpp b/src/addrman.cpp
-index 20a1efbc2..12948660d 100644
---- a/src/addrman.cpp
-+++ b/src/addrman.cpp
-@@ -90,7 +90,7 @@ double CAddrInfo::GetChance(int64_t nNow) const
- // deprioritize 66% after each failed attempt, but at most 1/28th to avoid the search taking forever or overly penalizing outages.
- fChance *= pow(0.66, std::min(nAttempts, 8));
-
-- if (fKnowsXThin)
-+ if (fKnowsXThin | fKnowsCash)
- fChance *= 1.5;
-
- return fChance;
-diff --git a/src/addrman.h b/src/addrman.h
-index 749bdf1a9..9469fcd57 100644
---- a/src/addrman.h
-+++ b/src/addrman.h
-@@ -75,6 +75,7 @@ public:
- nRefCount = 0;
- fInTried = false;
- fKnowsXThin = false;
-+ fKnowsCash = false;
- nRandomPos = -1;
- }
-
-@@ -439,6 +440,7 @@ public:
- auto info = mapInfo.find(index);
- if (info != mapInfo.end()) {
- info->second.setKnowsXThin(true);
-+ info->second.setKnowsCash(true);
- } else {
- LogPrintf("CAddMan: Warning, loading priority address out of range; %d\n", index);
- }
-diff --git a/src/main.cpp b/src/main.cpp
-index 2cf51ee4b..1af19ddb5 100644
---- a/src/main.cpp
-+++ b/src/main.cpp
-@@ -3181,7 +3181,7 @@ bool ContextualCheckBlock(const CBlock& block, CValidationState& state, CBlockIn
- // this is a UAHF-chain block!
- logInfo(8002) << "Check block found an UAHF chain block (based on timestamp)" << pindexPrev->nHeight + 1 << block.GetHash();
-
-- if (pindexPrev->pprev->GetMedianTimePast() < startTime) {
-+ if (pindexPrev->pprev && pindexPrev->pprev->GetMedianTimePast() < startTime) {
- logInfo(8002) << " + block is the anti-rollback block!" << pindexPrev->nHeight + 1 << "size:" << blockSize;
- // If UAHF is enabled for the curent block, but not for the previous
- // block, we must check that the block is larger than 1MB.