summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Schneider2016-02-25 00:03:32 +0100
committerSven Schneider2016-02-25 00:03:32 +0100
commita4761b3febfde9c1506480c4e027ee8a7135fbb3 (patch)
tree961c37de1d58ead6083fa8c9541e236de8f4d9f3
downloadaur-a4761b3febfde9c1506480c4e027ee8a7135fbb3.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19cef942df2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Feb 24 23:02:54 UTC 2016
+pkgbase = go-graphql-go
+ pkgdesc = GraphQL for Go
+ pkgver = 361.26c58bd
+ pkgrel = 1
+ url = https://github.com/graphql-go/graphql
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = rsync
+ depends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = go-graphql-go
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f985c5ea445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=go-graphql-go
+pkgver=361.26c58bd
+pkgrel=1
+pkgdesc="GraphQL for Go"
+arch=('x86_64' 'i686')
+url="https://github.com/graphql-go/graphql"
+license=('MIT')
+depends=('go')
+makedepends=('rsync')
+options=('!strip' '!emptydirs')
+_gourl='github.com/graphql-go/graphql'
+
+build() {
+ GOPATH="${srcdir}" go get -v -x ${_gourl}
+}
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/usr/lib/go"
+ rsync -avz --exclude .git {src,pkg} "${pkgdir}/usr/lib/go"
+
+ install -Dm644 "src/${_gourl}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}