summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Luc Tambasco2019-04-04 01:35:58 +1100
committerJean-Luc Tambasco2019-04-04 01:35:58 +1100
commita4793b5577578dd7db3215b0f15f8f75027095fa (patch)
tree596eff6558824b92f97502ef8047858c31f17029
parent617a251196058f11a35959af5b5624955de92fe7 (diff)
downloadaur-a4793b5577578dd7db3215b0f15f8f75027095fa.tar.gz
Removed patch.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--missingOp.patch15
3 files changed, 2 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c40a3e7170e2..902771d945ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = klayout-git
pkgdesc = High Performance Layout Viewer And Editor. Support of GDS and OASIS files.
- pkgver = v0.25.4.r517.g51ea5398
+ pkgver = v0.25.4.r47.g9dd603bb
pkgrel = 1
url = http://www.klayout.org/
arch = i686
@@ -16,11 +16,9 @@ pkgbase = klayout-git
source = klayout::git+https://github.com/klayoutmatthias/klayout#branch=master
source = klayoutEditor.desktop
source = klayoutViewer.desktop
- source = missingOp.patch
md5sums = SKIP
md5sums = e790f7fca3c1138e21068d7927fb8ff4
md5sums = e6b98e9146c476a5cb76162999964aa8
- md5sums = 553b08ddcf6c2338115a8c85ff1c948c
pkgname = klayout-git
diff --git a/PKGBUILD b/PKGBUILD
index 4829225ac7ad..59634b1e0dfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,10 @@ source=(
'klayout::git+https://github.com/klayoutmatthias/klayout#branch=master'
klayoutEditor.desktop
klayoutViewer.desktop
- missingOp.patch
)
md5sums=(SKIP
'e790f7fca3c1138e21068d7927fb8ff4'
- 'e6b98e9146c476a5cb76162999964aa8'
- '553b08ddcf6c2338115a8c85ff1c948c')
+ 'e6b98e9146c476a5cb76162999964aa8')
pkgver() {
cd "$_pkgname"
@@ -38,11 +36,6 @@ build() {
-j${threads}
-qt5"
- # apply patch
- cd ./src/db/db
- cat ../../../../../missingOp.patch | patch
- cd ../../../
-
./build.sh $build_opt
}
diff --git a/missingOp.patch b/missingOp.patch
deleted file mode 100644
index 1e1d8d628d1e..000000000000
--- a/missingOp.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- dbCellMapping.cc.o 2018-05-11 11:46:36.416064830 -0400
-+++ dbCellMapping.cc 2018-05-11 11:47:02.921846210 -0400
-@@ -75,6 +75,12 @@
- return *this;
- }
-
-+ SortedCellIndexIterator &operator--()
-+ {
-+ --m_n;
-+ return *this;
-+ }
-+
- SortedCellIndexIterator &operator+=(size_t n)
- {
- m_n += n;