summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commita4960e77927f9929e01e74462288b65b2da48962 (patch)
tree8ec2cb3e725f630f9fb14f0d0c7827f30498ae4a
downloadaur-a4960e77927f9929e01e74462288b65b2da48962.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD29
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59ffa2953286
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-cache-simple-timedexpiry
+ pkgdesc = Perl module providing a lightweight cache with timed expiration
+ pkgver = 0.27
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Cache-Simple-TimedExpiry/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/Cache-Simple-TimedExpiry-0.27.tar.gz
+ md5sums = 4ef124ab7776f3c257b9ffbed917e67a
+
+pkgname = perl-cache-simple-timedexpiry
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d127601bce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+pkgname=perl-cache-simple-timedexpiry
+pkgver=0.27
+pkgrel=1
+pkgdesc="Perl module providing a lightweight cache with timed expiration"
+arch=("any")
+url="http://search.cpan.org/dist/Cache-Simple-TimedExpiry/"
+license=("GPL" "PerlArtistic")
+depends=("perl")
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/Cache-Simple-TimedExpiry-$pkgver.tar.gz)
+md5sums=("4ef124ab7776f3c257b9ffbed917e67a")
+
+build() {
+ cd "$srcdir/Cache-Simple-TimedExpiry-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/Cache-Simple-TimedExpiry-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/Cache-Simple-TimedExpiry-$pkgver"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}