summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:15:35 +0100
committerDaniel Peukert2024-01-28 00:15:35 +0100
commita4b3545032c951a23c4f14393d6fb508863cd7f0 (patch)
treec927f610415df67044507b5d45ff8ba0bd8bdbdc
parent10f312a82985807be51f6f90aee652c4e5848252 (diff)
downloadaur-a4b3545032c951a23c4f14393d6fb508863cd7f0.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e00567e8cd6..b3fd7cb0985c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = ocaml-utop
url = https://github.com/ocaml-community/utop
arch = x86_64
arch = aarch64
- license = BSD
+ license = BSD-3-Clause
checkdepends = ocaml-alcotest
depends = ocaml>=4.11.0
depends = dune>=3.9.0
diff --git a/.gitignore b/.gitignore
index 004b0a3a8706..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
# which causes the gitignore file to apply to them too, which breaks some builds
-# Based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
/*.tar
/*.tar.*
/*.rpm
diff --git a/PKGBUILD b/PKGBUILD
index 1ab3258c5f99..55b758c9d157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgrel='1'
pkgdesc='Universal toplevel for OCaml'
arch=('x86_64' 'aarch64')
url="https://github.com/ocaml-community/$_projectname"
-license=('BSD')
+license=('BSD-3-Clause')
depends=('ocaml>=4.11.0' 'dune>=3.9.0' 'cppo>=1.1.2' 'ocaml-findlib>=1.7.2' 'ocaml-lambda-term>=3.1.0' 'ocaml-logs_lwt' 'ocaml-lwt' 'ocaml-react>=1.0.0' 'ocaml-zed>=3.2.0')
checkdepends=('ocaml-alcotest')
options=('!strip')
@@ -42,5 +42,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
}