summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-19 22:07:44 +0800
committerChocobo12017-08-19 22:25:36 +0800
commita4b7b0ddf96ec2aa2e9e834aa6258cffc3a19cfd (patch)
tree9a6c0b7034da4998474bdec88252830a01704ae7
downloadaur-a4b7b0ddf96ec2aa2e9e834aa6258cffc3a19cfd.tar.gz
newpkg: autoconf-git 2.69.r185.gb502e350-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb0b77ecdc04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = autoconf-git
+ pkgdesc = An extensible package of M4 macros that produce shell scripts to automatically configure software source code packages
+ pkgver = 2.69.r185.gb502e350
+ pkgrel = 1
+ url = https://www.gnu.org/software/autoconf/autoconf.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = Custom
+ makedepends = git
+ depends = glibc
+ depends = perl
+ depends = texinfo
+ provides = autoconf
+ conflicts = autoconf
+ source = git+https://git.savannah.gnu.org/git/autoconf.git
+ sha256sums = SKIP
+
+pkgname = autoconf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22a73fd15d22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=autoconf-git
+pkgver=2.69.r185.gb502e350
+pkgrel=1
+pkgdesc="An extensible package of M4 macros that produce shell scripts to automatically configure software source code packages"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/autoconf/autoconf.html"
+license=('GPL2' 'Custom')
+depends=('glibc' 'perl' 'texinfo')
+makedepends=('git')
+provides=('autoconf')
+conflicts=('autoconf')
+source=("git+https://git.savannah.gnu.org/git/autoconf.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "autoconf"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "autoconf"
+
+ autoreconf -fi
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "autoconf"
+
+ #make check
+}
+
+package() {
+ cd "autoconf"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING.EXCEPTION" "$pkgdir/usr/share/licenses/autoconf/COPYING.EXCEPTION"
+
+ rm "$pkgdir/usr/share/info/standards.info"
+}