summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordoragasu2016-07-17 17:20:28 +0200
committerdoragasu2016-07-17 17:20:28 +0200
commita4bb97e5a58db5e795599e49cc0d62e825ad574d (patch)
tree55252a7fc2b283593a50767140c4ce550e29db6e
downloadaur-a4bb97e5a58db5e795599e49cc0d62e825ad574d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD65
-rw-r--r--lattice-diamond.desktop9
-rw-r--r--lattice-diamond.pngbin0 -> 28999 bytes
-rw-r--r--synp-plat-check.patch37
5 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54817f8d5d4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lattice-diamond
+ pkgdesc = Lattice Diamond design software
+ pkgver = 3.7
+ pkgrel = 1
+ url = http://www.latticesemi.com/latticediamond
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ provides = lattice-diamond
+ conflicts = lattice-diamond
+ options = !strip
+ source = http://files.latticesemi.com/Diamond/3.7/diamond_3_7-base_x64-96-1-x86_64-linux.rpm
+ source = synp-plat-check.patch
+ source = lattice-diamond.png
+ source = lattice-diamond.desktop
+ md5sums = 162ab905a552a72763aa62dc3efe0ef7
+ md5sums = b03c61ceb13d196d651a6ed26f61c796
+ md5sums = d04fb58bdb5f67e44b5058e14f3aacf9
+ md5sums = fbba8b33146178b861871aabdc779fbd
+
+pkgname = lattice-diamond
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0a5537862ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: doragasu <doragasu (yawn) hotmail (roll) com>
+
+pkgname=lattice-diamond
+pkgver=3.7
+pkgrel=1
+pkgdesc="Lattice Diamond design software"
+arch=('x86_64')
+url="http://www.latticesemi.com/latticediamond"
+license=('custom')
+options=('!strip')
+makedepends=('rpmextract')
+provides=('lattice-diamond')
+conflicts=('lattice-diamond')
+source=(http://files.latticesemi.com/Diamond/3.7/diamond_3_7-base_x64-96-1-x86_64-linux.rpm
+ synp-plat-check.patch
+ lattice-diamond.png
+ lattice-diamond.desktop)
+md5sums=('162ab905a552a72763aa62dc3efe0ef7'
+ 'b03c61ceb13d196d651a6ed26f61c796'
+ 'd04fb58bdb5f67e44b5058e14f3aacf9'
+ 'fbba8b33146178b861871aabdc779fbd')
+
+prepare() {
+ # Extract all the packages
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/bin
+ tar -xzf bin.tar.gz
+ rm bin.tar.gz
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/cae_library
+ tar -xzf cae_library.tar.gz
+ rm cae_library.tar.gz
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/data
+ tar -xzf data.tar.gz
+ rm data.tar.gz
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/embedded_source
+ tar -xzf embedded_source.tar.gz
+ rm embedded_source.tar.gz
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/examples
+ tar -xzf examples.tar.gz
+ rm examples.tar.gz
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/ispfpga
+ tar -xzf ispfpga.tar.gz
+ rm ispfpga.tar.gz
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/synpbase
+ tar -xzf synpbase.tar.gz
+ rm synpbase.tar.gz
+ cd ${srcdir}/usr/local/diamond/${pkgver}_x64/tcltk
+ tar -xzf tcltk.tar.gz
+ rm tcltk.tar.gz
+}
+
+build() {
+ # Patch to skip platform check, allowing Synplify Pro to run on non
+ # officially supported platforms
+ patch -p1 < synp-plat-check.patch
+}
+
+package() {
+ # Move everything to pkgdir
+ mv ${srcdir}/usr ${pkgdir}/
+ # Copy .desktop and icon files
+ mkdir -p "${pkgdir}/usr/share/pixmaps"
+ cp "${srcdir}/lattice-diamond.png" "${pkgdir}/usr/share/pixmaps"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ cp "$srcdir/lattice-diamond.desktop" "$pkgdir/usr/share/applications/"
+}
diff --git a/lattice-diamond.desktop b/lattice-diamond.desktop
new file mode 100644
index 000000000000..2ff094310ea9
--- /dev/null
+++ b/lattice-diamond.desktop
@@ -0,0 +1,9 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=lattice-diamond
+Name=Lattice Diamond
+Exec=/usr/local/diamond/3.7_x64/bin/lin64/diamond
+Categories=Development;
+Comment=Lattice Diamond Design Software
diff --git a/lattice-diamond.png b/lattice-diamond.png
new file mode 100644
index 000000000000..4f6e5f3e037a
--- /dev/null
+++ b/lattice-diamond.png
Binary files differ
diff --git a/synp-plat-check.patch b/synp-plat-check.patch
new file mode 100644
index 000000000000..6689bdd3a967
--- /dev/null
+++ b/synp-plat-check.patch
@@ -0,0 +1,37 @@
+diff -ruN src/usr/local/diamond/3.7_x64/synpbase/bin/config/platform_check src.work/usr/local/diamond/3.7_x64/synpbase/bin/config/platform_check
+--- src/usr/local/diamond/3.7_x64/synpbase/bin/config/platform_check 2015-12-09 21:12:13.000000000 +0100
++++ src.work/usr/local/diamond/3.7_x64/synpbase/bin/config/platform_check 2016-07-17 15:32:55.368029939 +0200
+@@ -9,18 +9,21 @@
+ # $Header: //synplicity/ui201509rc/unix_scripts/bin/config/platform_check#2 $
+ #
+ #+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
+-case $PLATFORM in
+- linux | linux_a_64 )
+- case $VERSION in
+- 3.* | 2.4.* | 2.6.* )
+- PLATFORM_STATUS="ok";;
+- *)
+- PLATFORM_STATUS=`echo $PLATFORM $VERSION`;;
+- esac;;
+- *)
+- PLATFORM_STATUS=`echo $PLATFORM $VERSION`
+- ;;
+-esac
++# Skip platform check to allow running on non officially supported platforms
++#case $PLATFORM in
++# linux | linux_a_64 )
++# case $VERSION in
++# 3.* | 2.4.* | 2.6.* )
++# PLATFORM_STATUS="ok";;
++# *)
++# PLATFORM_STATUS=`echo $PLATFORM $VERSION`;;
++# esac;;
++# *)
++# PLATFORM_STATUS=`echo $PLATFORM $VERSION`
++# ;;
++#esac
++
++PLATFORM_STATUS="ok"
+
+ #+-+-+-+-+-+-+-+- Platform Checking +-+-+-+-+-+-+
+ #