summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Griffis2015-09-14 19:18:00 -0400
committerPatrick Griffis2015-09-14 19:18:00 -0400
commita4c1a37965d23033f990105213f8cc2384c10483 (patch)
tree7a0ceb3b84bba60fa222c7ec6745b9886c684726
downloadaur-a4c1a37965d23033f990105213f8cc2384c10483.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26d509212a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = git-bz-git
+ pkgdesc = Bugzilla subcommand for Git
+ pkgver = r169.e17bbae
+ pkgrel = 1
+ url = http://blog.fishsoup.net/2008/11/16/git-bz-bugzilla-subcommand-for-git/
+ arch = any
+ license = GPL2
+ makedepends = xmlto
+ makedepends = asciidoc
+ depends = git
+ depends = python2
+ source = git://git.fishsoup.net/git-bz
+ md5sums = SKIP
+
+pkgname = git-bz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad68d7ea324a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Techlive Zheng <techlivezheng@gmail.com>
+# Maintainer: TingPing <tingping@tingping.se>
+
+_gitname=git-bz
+pkgname=git-bz-git
+pkgver=r169.e17bbae
+pkgrel=1
+pkgdesc='Bugzilla subcommand for Git'
+arch=('any')
+url='http://blog.fishsoup.net/2008/11/16/git-bz-bugzilla-subcommand-for-git/'
+license=('GPL2')
+depends=('git' 'python2')
+makedepends=('xmlto' 'asciidoc')
+source=('git://git.fishsoup.net/git-bz')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_gitname"
+
+ sed -i 's/python$/python2/' git-bz
+}
+build() {
+ cd "$_gitname"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_gitname"
+
+ DESTDIR="$pkgdir" make install
+}