summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-02-04 13:03:16 +0100
committertytan6522022-02-04 13:03:16 +0100
commita513e8fa53e282d51dbab32ba0e9b31214c406ce (patch)
treef88e4e34f324bc63bd7e5069a9bf360d4e52a0d0
parent1f30d79ab55cd50a338645f41f6f0c66b1670996 (diff)
downloadaur-a513e8fa53e282d51dbab32ba0e9b31214c406ce.tar.gz
build: Enable debug symbol
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cab791ce1ea2..d3494a04cb0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-vnc
pkgdesc = This plugin is a VNC viewer that works as a source in OBS Studio
pkgver = 0.4.0
- pkgrel = 2
+ pkgrel = 3
url = https://obsproject.com/forum/resources/vnc-source.1000/
arch = i686
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = obs-vnc
makedepends = cmake
depends = obs-studio
depends = libvncserver
+ options = debug
source = obs-vnc-0.4.0.tar.gz::https://github.com/norihiro/obs-vnc/archive/0.4.0.tar.gz
sha256sums = c61397314c7cc0518beb7cfcfa89a391039241200fad0e61d01552a3ceceaa57
diff --git a/PKGBUILD b/PKGBUILD
index 4575a76427d7..6503b174c045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,21 @@
pkgname=obs-vnc
pkgver=0.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="This plugin is a VNC viewer that works as a source in OBS Studio"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/vnc-source.1000/"
license=("GPL2")
depends=("obs-studio" "libvncserver")
makedepends=("cmake")
+options=('debug')
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/norihiro/$pkgname/archive/$pkgver.tar.gz")
sha256sums=("c61397314c7cc0518beb7cfcfa89a391039241200fad0e61d01552a3ceceaa57")
build() {
cd "$pkgname-$pkgver"
cmake -B build \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX='/usr'
make -C build
}