summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2018-07-11 15:10:06 +0200
committerJake2018-07-11 15:10:06 +0200
commita51a51a6ef0c74cae7dbe21c48b19a20425e5eb2 (patch)
tree59d38508efd5413d09c935d971ea49e069216010
parentd9f677321a4678927dae40e07962e714da834ed8 (diff)
downloadaur-a51a51a6ef0c74cae7dbe21c48b19a20425e5eb2.tar.gz
Use offical archive and drop git makedepend
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b0f1b797cbd..28c8bd02de39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blackbox-explorer
pkgdesc = Cleanflight and Betaflight Blackbox Explorer (NW.js build)
pkgver = 3.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/betaflight/blackbox-log-viewer
arch = x86_64
license = GPL3
@@ -11,12 +11,12 @@ pkgbase = blackbox-explorer
depends = nwjs-bin>=0.31.0
depends = nwjs-ffmpeg-codecs-bin
options = !strip
- source = git+https://github.com/betaflight/blackbox-log-viewer.git#commit=84f8abd7463e65773921635b57c7ac8fd4104ce9
+ source = https://github.com/betaflight/blackbox-log-viewer/archive/3.1.0.tar.gz
source = blackbox-explorer.sh
source = blackbox-explorer.desktop
- sha256sums = SKIP
- sha256sums = 95635caffae7a586612f10abbc8248764ddde4f7192d8ed65d7a3c1e2e689c1d
- sha256sums = bc9ba2824d722c0872d952ffe30b6fc88583eacd97e2c614a28e2847668a4554
+ sha512sums = 873473584c43198b3d4e257d8752836ec6ca3e8764ddb8f4f1c3a5c64366d26530bfdb9ebecd0a3c218315350b6e9fd745a69c961aded9cece404eceb30492ec
+ sha512sums = d5e10ddba597043b75e7a5e02bf23d4bf1c6c64907c9b187e2e48bed045e001abaaec062b39bd9040222d1693758a54112d56d92538cb8b717d2b60d41175fa4
+ sha512sums = c06b498dfa438002ee9f5f4e90276b051762a936057b6b513e207106f727978fd301d8c131ab320cedc50eb86e46f1f8905b867caf1e6d550fda54985a2529ae
pkgname = blackbox-explorer
diff --git a/PKGBUILD b/PKGBUILD
index 8f57d42a7cee..d67324830a1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,29 @@
pkgname=blackbox-explorer
_reponame=blackbox-log-viewer
pkgver=3.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Cleanflight and Betaflight Blackbox Explorer (NW.js build)"
arch=("x86_64")
url="https://github.com/betaflight/${_reponame}"
license=('GPL3')
depends=('nwjs-bin>=0.31.0' 'nwjs-ffmpeg-codecs-bin')
-makedepends=('yarn' 'npm' 'git')
-source=("git+https://github.com/betaflight/${_reponame}.git#commit=84f8abd7463e65773921635b57c7ac8fd4104ce9"
+makedepends=('yarn' 'npm')
+source=("https://github.com/betaflight/${_reponame}/archive/$pkgver.tar.gz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('SKIP'
- '95635caffae7a586612f10abbc8248764ddde4f7192d8ed65d7a3c1e2e689c1d'
- 'bc9ba2824d722c0872d952ffe30b6fc88583eacd97e2c614a28e2847668a4554')
+sha512sums=('873473584c43198b3d4e257d8752836ec6ca3e8764ddb8f4f1c3a5c64366d26530bfdb9ebecd0a3c218315350b6e9fd745a69c961aded9cece404eceb30492ec'
+ 'd5e10ddba597043b75e7a5e02bf23d4bf1c6c64907c9b187e2e48bed045e001abaaec062b39bd9040222d1693758a54112d56d92538cb8b717d2b60d41175fa4'
+ 'c06b498dfa438002ee9f5f4e90276b051762a936057b6b513e207106f727978fd301d8c131ab320cedc50eb86e46f1f8905b867caf1e6d550fda54985a2529ae')
options=(!strip)
build() {
- cd "$_reponame"
+ cd "$_reponame-$pkgver"
yarn install
./node_modules/.bin/gulp dist --linux64
}
package() {
- cd "$_reponame"
+ cd "$_reponame-$pkgver"
install -d "$pkgdir/usr/share/$pkgname/"
cp -r dist/* "$pkgdir/usr/share/$pkgname/"
install -D "assets/linux/icon/bf_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"