summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-05-26 18:06:04 +0200
committerChristopher Arndt2016-05-26 18:06:40 +0200
commita51d549c5fcb02129f27dc553208b519d3027cde (patch)
treead76222064155f93ff054b4aa110f4cf74d6694b
parent29ca5fb85ac29fab9b1aded8f791f5acf7ba2f7c (diff)
downloadaur-a51d549c5fcb02129f27dc553208b519d3027cde.tar.gz
Add make dependency on gcc5
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO5
-rw-r--r--ChangeLog6
-rw-r--r--PKGBUILD22
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 242273605776..810b4e35f971 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Sun Mar 6 06:30:00 UTC 2016
+# Thu May 26 16:06:09 UTC 2016
pkgbase = python26
pkgdesc = Legacy version Python 2.6 of the high-level scripting language
pkgver = 2.6.9
- pkgrel = 7
+ pkgrel = 8
url = http://www.python.org/
changelog = ChangeLog
arch = i686
arch = x86_64
arch = arm
license = PSF
+ makedepends = gcc5
makedepends = tk>=8.5.0
depends = db>=4.8
depends = bzip2
diff --git a/ChangeLog b/ChangeLog
index ca1f5215039f..6b27e483d3ab 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2016-05-26 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 2.6.9-8 :
+ Added 'gcc5' as a make dependency to keep compiling this package with
+ GCC 5.3 instaed of the now default GCC 6.1, which breaks many things.
+
2016-03-06 Christopher Arndt <aur -at- chrisarndt -dot- de>
* 2.6.9-7 :
diff --git a/PKGBUILD b/PKGBUILD
index ee3044d7d81f..c58ffe3527e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=python26
pkgver=2.6.9
-pkgrel=7
+pkgrel=8
_pybasever=2.6
pkgdesc="Legacy version Python 2.6 of the high-level scripting language"
arch=('i686' 'x86_64' 'arm')
license=('PSF')
url="http://www.python.org/"
depends=('db>=4.8' 'bzip2' 'gdbm' 'openssl' 'zlib' 'expat' 'sqlite3' 'libffi')
-makedepends=('tk>=8.5.0')
+makedepends=('gcc5' 'tk>=8.5.0')
optdepends=('tk: for IDLE, pynche and modulator')
provides=(python2=${pkgver})
changelog=ChangeLog
@@ -87,6 +87,11 @@ build() {
export OPT="${CFLAGS}"
export CPPFLAGS="-DOPENSSL_NO_SSL3"
+ # A lot of tests fail under GCC >= 6.x
+ export CPP="cpp-5"
+ export CC="gcc-5"
+ export CXX="g++-5"
+
./configure --prefix=/usr \
--enable-shared \
--enable-ipv6 \
@@ -94,6 +99,7 @@ build() {
--with-system-ffi \
--with-threads
+ make clean
make MACHDEP=linux2
}
@@ -108,9 +114,13 @@ check() {
return 1
fi
- # test_float fails on arm
- # issue with no fix: http://bugs.python.org/issue8265
+ export CPP="cpp-5"
+ export CC="gcc-5"
+ export CXX="g++-5"
+
if [ "x$CARCH" = "xarm" ]; then
+ # test_float fails on arm
+ # issue with no fix: http://bugs.python.org/issue8265
LD_LIBRARY_PATH="$(pwd)" ./python Lib/test/regrtest.py -x test_float
else
make test
@@ -120,6 +130,10 @@ check() {
package() {
cd "${srcdir}/Python-${pkgver}"
+ export CPP="cpp-5"
+ export CC="gcc-5"
+ export CXX="g++-5"
+
make DESTDIR="${pkgdir}" altinstall maninstall
ln -sf ../../libpython${_pybasever}.so \