summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordx-mon2020-10-16 00:45:29 +0100
committerdx-mon2020-10-16 00:45:29 +0100
commita56eb19f8c5a2080f5b9d808d36a1bc456b7df8f (patch)
treeab36fb0888256234ee5cbd015d87f58376b7eb7f
parent80d5ed5eb6fc05b5eebdc3ae4c29eaa123e18341 (diff)
downloadaur-a56eb19f8c5a2080f5b9d808d36a1bc456b7df8f.tar.gz
Improved the package update script to automate the commit phase
-rwxr-xr-xupdatePackage14
1 files changed, 12 insertions, 2 deletions
diff --git a/updatePackage b/updatePackage
index 62a64afbeb26..5abe619c8716 100755
--- a/updatePackage
+++ b/updatePackage
@@ -9,13 +9,18 @@ _update()
cd ..
}
-_kicadVersion()
+_kicadRawVersion()
{
cd kicad
- git describe --tag | sed 's/-/_/g'
+ git describe --tag
cd ..
}
+_kicadVersion()
+{
+ _kicadRawVersion | sed 's/-/_/g'
+}
+
_kicadHash()
{
cd kicad
@@ -46,3 +51,8 @@ _updateSRCINFO()
_update
_buildPKGBUILD
_updateSRCINFO
+version=`_kicadRawVersion`
+
+git add PKGBUILD .SRCINFO
+git commit -m "Bump to KiCAD $version"
+echo $version