summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2017-02-07 14:38:09 +0100
committerSanskritFritz2017-02-07 14:38:09 +0100
commita577441367e7ef94f8329bef8adda17c4f2b44bd (patch)
treea68575f7e69e9265ed032ae6da2f28b82d0eb4c8
parenta80414a895173d03fce73b7a7fa940a8990eabe1 (diff)
downloadaur-a577441367e7ef94f8329bef8adda17c4f2b44bd.tar.gz
Included waf now runs with python3.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9936a10926e5..15324e8cbfc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Feb 6 14:07:29 UTC 2017
+# Tue Feb 7 13:37:19 UTC 2017
pkgbase = kupfer-git
pkgdesc = An interface for quick and convenient access to applications and their documents.
- pkgver = v301.r2.g2bae3642
+ pkgver = v302.r11.gd8419c31
pkgrel = 1
url = https://kupferlauncher.github.io/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 4c5018f45b69..c122484d0cea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_name=kupfer
pkgname=$_name-git
-pkgver=v301.r2.g2bae3642
+pkgver=v302.r11.gd8419c31
pkgrel=1
pkgdesc="An interface for quick and convenient access to applications and their documents."
arch=(any)
url="https://kupferlauncher.github.io/"
license=('GPL')
depends=('libkeybinder3' 'python-dbus' 'python' 'python-cairo' 'libwnck3')
-makedepends=('python2' 'intltool')
+makedepends=('intltool')
optdepends=('gnome-python-desktop: enables all plugins and gnome integration'
'xautomation: enables the Send Keys plugin')
makedepends=('python2' 'intltool' 'git')
@@ -29,15 +29,15 @@ build() {
cd "$srcdir/$_name"
# fix man page generation
- sed -i 's_rst2man_&2_Ig' wscript
+ #sed -i 's_rst2man_&2_Ig' wscript
- export PYTHON=/usr/bin/python
+ #export PYTHON=/usr/bin/python
- python2 waf configure --prefix=/usr --no-update-mime --no-update-icon-cache
- python2 waf
+ python waf configure --prefix=/usr --no-update-mime --no-update-icon-cache
+ python waf
}
package() {
cd "$srcdir/$_name"
- python2 waf install -f --destdir="$pkgdir/"
+ python waf install -f --destdir="$pkgdir/"
}