summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Milette2017-09-12 12:30:22 -0400
committerCharles Milette2017-09-12 12:30:22 -0400
commita578c54a34bb577e4e7982c0d4e9b21b3a07617e (patch)
treeb2a22fc5f7f5015a11fdc2fb19f3193b9333a823
downloadaur-a578c54a34bb577e4e7982c0d4e9b21b3a07617e.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD51
-rw-r--r--change-solid-theme-path.patch28
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb5f608e8505
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = arc-orange-gtk-theme-git
+ pkgver = r57.af13f6a
+ pkgrel = 1
+ url = https://github.com/eti0/arc-theme-orange
+ arch = any
+ license = GPL3
+ makedepends = gtk3
+ optdepends = arc-icon-theme: recommended icon theme
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ optdepends = gnome-themes-standard: for gtk2 themes
+ source = git+https://github.com/eti0/arc-theme-orange.git
+ source = change-solid-theme-path.patch
+ sha512sums = SKIP
+ sha512sums = 5b1ca739206e386cb4bf1f2f0a9524a08f2590972126cc96ef7c2e56ca59e94136cf7f8dc8184cd1c688a488e5e96384d654e279778f93e8f34860f7281afff9
+
+pkgname = arc-orange-gtk-theme-git
+ pkgdesc = A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell
+
+pkgname = arc-orange-solid-gtk-theme-git
+ pkgdesc = A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c46e2832bc48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Charles Milette <charles.milette@gmail.com>
+# Originally taken from https://www.archlinux.org/packages/community/any/arc-gtk-theme/
+
+pkgbase=arc-orange-gtk-theme-git
+_pkgname=arc-theme-orange
+pkgname=('arc-orange-gtk-theme-git' 'arc-orange-solid-gtk-theme-git')
+pkgver=r57.af13f6a
+pkgrel=1
+arch=('any')
+url="https://github.com/eti0/${_pkgname}"
+license=('GPL3')
+optdepends=('arc-icon-theme: recommended icon theme'
+ 'gtk-engine-murrine: for gtk2 themes'
+ 'gnome-themes-standard: for gtk2 themes')
+makedepends=('gtk3')
+source=("git+https://github.com/eti0/${_pkgname}.git"
+ 'change-solid-theme-path.patch')
+sha512sums=('SKIP'
+ '5b1ca739206e386cb4bf1f2f0a9524a08f2590972126cc96ef7c2e56ca59e94136cf7f8dc8184cd1c688a488e5e96384d654e279778f93e8f34860f7281afff9')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cp -a ${_pkgname}{,-solid}
+ cd ${_pkgname}-solid
+ patch -p1 -i ../change-solid-theme-path.patch
+}
+
+build() {
+ cd ${_pkgname}
+ ./autogen.sh --prefix=/usr
+
+ cd ../${_pkgname}-solid
+ ./autogen.sh --prefix=/usr --disable-transparency
+}
+
+package_arc-orange-gtk-theme-git() {
+ pkgdesc="A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell"
+
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
+}
+
+package_arc-orange-solid-gtk-theme-git() {
+ pkgdesc="A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)"
+
+ cd ${_pkgname}-solid
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/change-solid-theme-path.patch b/change-solid-theme-path.patch
new file mode 100644
index 000000000000..c1e51e880ed9
--- /dev/null
+++ b/change-solid-theme-path.patch
@@ -0,0 +1,28 @@
+From 7b1d4f3fb9635c21abc4221c008cfa9849fe53ff Mon Sep 17 00:00:00 2001
+From: Patrick Griffis <tingping@tingping.se>
+Date: Wed, 10 May 2017 17:38:54 -0400
+Subject: [PATCH] Append solid suffix to non-transparent variant
+
+This allows distributions to easily pacakge both without conflicts.
+This will also help with Flatpak being able to match the host theme.
+---
+ common/Makefile.am | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/common/Makefile.am b/common/Makefile.am
+index 0421c5de1..58f54d840 100644
+--- a/common/Makefile.am
++++ b/common/Makefile.am
+@@ -1,6 +1,12 @@
++if !ENABLE_TRANSPARENCY
++themedir = $(datadir)/themes/Arc-solid
++themedarkerdir = $(datadir)/themes/Arc-Darker-solid
++themedarkdir = $(datadir)/themes/Arc-Dark-solid
++else
+ themedir = $(datadir)/themes/Arc
+ themedarkerdir = $(datadir)/themes/Arc-Darker
+ themedarkdir = $(datadir)/themes/Arc-Dark
++endif
+
+ ithemedir = $(DESTDIR)$(themedir)
+ ithemedarkerdir = $(DESTDIR)$(themedarkerdir)