summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorR. V. Lobato2022-10-27 17:32:17 -0500
committerR. V. Lobato2022-10-27 17:32:17 -0500
commita58222dae5ebc9e671fdc8ffc293a66e256d797d (patch)
treee68acd54a5b85061b9b336b01edb0414d2ab936c
parent93cadea26f472accbe270cf21d3b1c684802f6b9 (diff)
downloadaur-a58222dae5ebc9e671fdc8ffc293a66e256d797d.tar.gz
upgpkg cadabra2 2.4.2.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3197b1d126b2..6459719fc677 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,31 @@
pkgbase = cadabra2
pkgdesc = A field-theory motivated approach to computer algebra
- pkgver = 2.4.0.2
+ pkgver = 2.4.2.1
pkgrel = 1
url = https://cadabra.science
arch = x86_64
license = GPL
makedepends = boost
makedepends = cmake
+ makedepends = pybind11
depends = boost-libs
depends = glibmm
depends = gmp
depends = gtkmm3
depends = jsoncpp
- depends = mathjax
- depends = python-ipykernel
+ depends = python
+ depends = python-gmpy2
+ depends = jupyterlab
depends = python-matplotlib
depends = python-sympy
depends = sqlite
+ depends = texlive-bin
depends = texlive-latexextra
depends = texlive-science
+ optdepends = mathjax: Doxygen documentation
+ optdepends = doxygen: Doxygen documentation
conflicts = cadabra2-git
- source = cadabra2-2.4.0.2.tar.gz::https://github.com/kpeeters/cadabra2/archive/2.4.0.2.tar.gz
- sha256sums = a24c8636264f2278c16d4f2010ab92b497b292a3a5bc495557c70e457516e7fe
+ source = cadabra2-2.4.2.1.tar.gz::https://github.com/kpeeters/cadabra2/archive/2.4.2.1.tar.gz
+ sha256sums = 9cdee23f92e99813f76be6864aa3b0cf4711c4635ea5f90ec9dcbef5858f4045
pkgname = cadabra2
diff --git a/PKGBUILD b/PKGBUILD
index 4ac63c688a7b..9dda1e1ba2a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,24 @@
# Contributor: Tarn Burton <twburton at gmail dot com>
pkgname=cadabra2
-pkgver=2.4.0.2
+pkgver=2.4.2.1
pkgrel=1
pkgdesc="A field-theory motivated approach to computer algebra"
arch=('x86_64')
url="https://cadabra.science"
license=('GPL')
conflicts=('cadabra2-git')
-depends=(boost-libs glibmm gmp gtkmm3 jsoncpp mathjax python-ipykernel python-matplotlib
- python-sympy sqlite texlive-latexextra texlive-science)
+depends=(boost-libs glibmm gmp gtkmm3 jsoncpp python python-gmpy2 jupyterlab python-matplotlib
+ python-sympy sqlite texlive-bin texlive-latexextra texlive-science)
-makedepends=(boost cmake)
+optdepends=('mathjax: Doxygen documentation'
+ 'doxygen: Doxygen documentation'
+ )
+
+makedepends=(boost cmake pybind11)
source=($pkgname-$pkgver.tar.gz::"https://github.com/kpeeters/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('a24c8636264f2278c16d4f2010ab92b497b292a3a5bc495557c70e457516e7fe')
+sha256sums=('9cdee23f92e99813f76be6864aa3b0cf4711c4635ea5f90ec9dcbef5858f4045')
prepare() {
mkdir -p "$srcdir/build"