summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2020-05-23 02:47:17 +0300
committerSergej Pupykin2020-05-23 02:47:17 +0300
commita5d01fa65fc8c914888c70497cf03419b7b1a735 (patch)
tree735519e20657ddc2c0165c9638dbfffc95c5f991
parent0c079a512db711c824d18e9eaa313582e1a9ce1a (diff)
downloadaur-a5d01fa65fc8c914888c70497cf03419b7b1a735.tar.gz
upd
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--conf.xml12
-rw-r--r--webdavd.logrotate10
-rw-r--r--webdavd.pam4
-rw-r--r--webdavd.service12
6 files changed, 61 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 994864e16aa2..4c4b075a0291 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webdav-daemon
pkgdesc = WebDAV server designed to be a replace for SMBA providing access to a system's files without taking ownership of them
pkgver = v1.1.r1.bc88ec6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/couling/WebDAV-Daemon
arch = x86_64
license = MIT
@@ -10,8 +10,16 @@ pkgbase = webdav-daemon
backup = etc/logrotate.d/webdavd
backup = etc/pam.d/webdavd
source = git+https://github.com/couling/WebDAV-Daemon.git
+ source = conf.xml
+ source = webdavd.logrotate
+ source = webdavd.pam
+ source = webdavd.service
source = build-fix.patch
md5sums = SKIP
+ md5sums = a9bfe1e242db185bfd8bc0acbde24610
+ md5sums = 305484a532e6e9be0e491cec5457c047
+ md5sums = cce88995b96d78aebfbaa6cc865eb535
+ md5sums = dddf8fd7c52bd3807eb7d9b8daef02db
md5sums = a2ef51c60c732ed1a152606e1157568a
pkgname = webdav-daemon
diff --git a/PKGBUILD b/PKGBUILD
index e713c9e40155..08b049a95b7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgver() {
cd "WebDAV-Daemon"
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-pkgrel=1
+pkgrel=2
pkgdesc="WebDAV server designed to be a replace for SMBA providing access to a system's files without taking ownership of them"
arch=(x86_64)
url="https://github.com/couling/WebDAV-Daemon"
@@ -15,8 +15,16 @@ backup=('etc/webdavd/conf.xml'
'etc/logrotate.d/webdavd'
'etc/pam.d/webdavd')
source=("git+https://github.com/couling/WebDAV-Daemon.git"
+ conf.xml
+ webdavd.logrotate
+ webdavd.pam
+ webdavd.service
build-fix.patch)
md5sums=('SKIP'
+ 'a9bfe1e242db185bfd8bc0acbde24610'
+ '305484a532e6e9be0e491cec5457c047'
+ 'cce88995b96d78aebfbaa6cc865eb535'
+ 'dddf8fd7c52bd3807eb7d9b8daef02db'
'a2ef51c60c732ed1a152606e1157568a')
prepare() {
@@ -33,13 +41,13 @@ package() {
cd "WebDAV-Daemon"
install -dm0755 "$pkgdir/usr/share/webdavd"
- install -Dm0644 package-with/conf.xml "$pkgdir/etc/webdavd/conf.xml"
- install -Dm0644 package-with/logrotate.conf "$pkgdir/etc/logrotate.d/webdavd"
- install -Dm0644 package-with/pam.conf "$pkgdir/etc/pam.d/webdavd"
- install -Dm0644 package-with/systemd.service "$pkgdir/usr/lib/systemd/system/webdavd.service"
+ install -Dm0644 package-with/conf.xml "$pkgdir/etc/webdavd/conf.xml.documented"
install -m0644 package-with/share/* "$pkgdir/usr/share/webdavd/"
- install -Dm0644 useful/conf.xml "$pkgdir/etc/webdavd/conf.xml.example"
+ install -Dm0644 "$srcdir"/webdavd.logrotate "$pkgdir/etc/logrotate.d/webdavd"
+ install -Dm0644 "$srcdir"/webdavd.pam "$pkgdir/etc/pam.d/webdavd"
+ install -Dm0644 "$srcdir"/webdavd.service "$pkgdir/usr/lib/systemd/system/webdavd.service"
+ install -Dm0644 "$srcdir"/conf.xml "$pkgdir/etc/webdavd/conf.xml"
install -Dm0755 build/rap "$pkgdir/usr/bin/rap"
install -Dm0755 build/webdavd "$pkgdir/usr/bin/webdavd"
diff --git a/conf.xml b/conf.xml
new file mode 100644
index 000000000000..4f296cbb2066
--- /dev/null
+++ b/conf.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="utf-8" ?>
+<server-config xmlns="http://couling.me/webdavd">
+ <server>
+ <listen>
+ <port>8080</port>
+ <encryption>none</encryption>
+ </listen>
+ <rap-binary>/usr/bin/rap</rap-binary>
+ <static-response-dir>/usr/share/webdavd</static-response-dir>
+ <chroot-path>~</chroot-path>
+ </server>
+</server-config>
diff --git a/webdavd.logrotate b/webdavd.logrotate
new file mode 100644
index 000000000000..eaf849f6542f
--- /dev/null
+++ b/webdavd.logrotate
@@ -0,0 +1,10 @@
+/var/log/webdav-access.log /var/log/webdav-error.log {
+ sharedscripts
+ missingok
+ delaycompress
+ create 640 root adm
+
+ postrotate
+ systemctl restart webdavd
+ endscript
+}
diff --git a/webdavd.pam b/webdavd.pam
new file mode 100644
index 000000000000..34e32d41b300
--- /dev/null
+++ b/webdavd.pam
@@ -0,0 +1,4 @@
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
diff --git a/webdavd.service b/webdavd.service
new file mode 100644
index 000000000000..6dd19c9f785a
--- /dev/null
+++ b/webdavd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=WebDAV file server
+Documentation=man:webdavd(1)
+
+[Service]
+Type=simple
+Environment=statedir=/var/cache/webdavd
+ExecStartPre=/usr/bin/mkdir -p ${statedir}
+ExecStart=/usr/bin/webdavd /etc/webdavd/conf.xml
+
+[Install]
+WantedBy=multi-user.target