summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngel Perez2021-07-29 22:31:13 -0400
committerAngel Perez2021-07-29 22:31:13 -0400
commita6138f9567393a870cb535032b6b9c7a985fc3f6 (patch)
tree3b9f0237def49da711a28bd520d8fcaefce78e92
parent71b2cb623707f0d544e68a7005d3a84863682387 (diff)
downloadaur-a6138f9567393a870cb535032b6b9c7a985fc3f6.tar.gz
Updated grub to 2.06
-rwxr-xr-x.SRCINFO11
-rw-r--r--08-fix_wrong_image_size.patch48
-rw-r--r--PKGBUILD10
3 files changed, 7 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 035e47d2bb6e..27204ce2eae3 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grub-silent
pkgdesc = GNU GRand Unified Bootloader (2) [without welcome and kernel messages]
- pkgver = 2.04
- pkgrel = 5
+ pkgver = 2.06
+ pkgrel = 1
url = https://www.gnu.org/software/grub/
install = grub.install
arch = x86_64
@@ -43,7 +43,7 @@ pkgbase = grub-silent
replaces = grub-efi-x86_64
options = !makeflags
backup = etc/default/grub
- source = https://ftp.gnu.org/gnu/grub/grub-2.04.tar.xz
+ source = https://ftp.gnu.org/gnu/grub/grub-2.06.tar.xz
source = https://git.savannah.nongnu.org/cgit/grub-extras.git/snapshot/grub-extras-8a245d5c1800627af4cefa99162a89c7a46d8842.tar.gz
source = 01-intel-ucode.patch
source = 02-linux-detect-archlinux-initramfs.patch
@@ -52,9 +52,8 @@ pkgbase = grub-silent
source = 05-sleep_shift.patch
source = 06-maybe_quiet.patch
source = 07-quick_boot.patch
- source = 08-fix_wrong_image_size.patch
source = grub.silent
- sha256sums = e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d
+ sha256sums = b79ea44af91b93d17cd3fe80bdae6ed43770678a9a5ae192ccea803ebb657ee1
sha256sums = fb6b37db9b14fd03e4d26775d84b570fbe91d4ea5de3df4e31114d79a2dfa97e
sha256sums = d101e9d33fbc67f7aaf6fb1191ec1315e8e5572c1d0538b95746ee194b8860db
sha256sums = b6e1c57dc9632ddf14e0acd96c5182cb4491994b67765cb11518d1356b603879
@@ -63,8 +62,6 @@ pkgbase = grub-silent
sha256sums = 4b189e00a8c97ec09903e9588e02fc78b4bb114ee4822fcce13811aca00c8884
sha256sums = b7489c7facc4fb3dad4426c9c00079b64908640a2bec2409e22194daa3f72af4
sha256sums = 1723340737b91a5bf503829bbe66b1c56683ef0e533f20d18b7098840aecb3a2
- sha256sums = 13053d6f36456234a5ed7dc4d4006459f6f9d2c9a19e6febfa4dc17cb5982bd3
sha256sums = 4f2e9d585b7b0ef8ce0d09e88391d1397b50883c7cb1516dc99785934abe15a2
pkgname = grub-silent
-
diff --git a/08-fix_wrong_image_size.patch b/08-fix_wrong_image_size.patch
deleted file mode 100644
index 17989adf3f87..000000000000
--- a/08-fix_wrong_image_size.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From c0e647eb0e2bd09315612446cb4d90f7f75cb44c Mon Sep 17 00:00:00 2001
-From: Javier Martinez Canillas <javierm@redhat.com>
-Date: Tue, 27 Apr 2021 12:25:08 +0200
-Subject: util/mkimage: Fix wrong PE32+ section sizes for some arches
-
-The commit f60ba9e5945 (util/mkimage: Refactor section setup to use a helper)
-added a helper function to setup PE sections. But it also changed how the
-raw data offsets were calculated since all the section sizes are aligned.
-However, for some platforms, i.e ia64-efi and arm64-efi, the kernel image
-size is not aligned using the section alignment. This leads to the situation
-in which the mods section offset in its PE section header does not match its
-real placement in the PE file. So, finally the GRUB is not able to locate
-and load built-in modules.
-
-The problem surfaces on ia64-efi and arm64-efi because both platforms
-require additional relocation data which is added behind .bss section.
-So, we have to add some padding behind this extra data to make the
-beginning of mods section properly aligned in the PE file. Fix it by
-aligning the kernel_size to the section alignment. That makes the sizes
-and offsets in the PE section headers to match relevant sections in the
-PE32+ binary file.
-
-Reported-by: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
-Tested-by: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
----
- util/grub-mkimagexx.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/util/grub-mkimagexx.c b/util/grub-mkimagexx.c
-index 00f49ccaa..d78fa3e53 100644
---- a/util/grub-mkimagexx.c
-+++ b/util/grub-mkimagexx.c
-@@ -2388,6 +2388,10 @@ SUFFIX (grub_mkimage_load_image) (const char *kernel_path,
- layout->kernel_size += ALIGN_UP (layout->got_size, 16);
- }
- #endif
-+
-+ if (image_target->id == IMAGE_EFI)
-+ layout->kernel_size = ALIGN_UP (layout->kernel_size,
-+ GRUB_PE32_FILE_ALIGNMENT);
- }
- else
- {
---
-cgit v1.2.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 6efd71f223ff..31c4486f73d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,8 +23,8 @@ _GRUB_EXTRAS_COMMIT="8a245d5c1800627af4cefa99162a89c7a46d8842"
pkgname="grub-silent"
pkgdesc="GNU GRand Unified Bootloader (2) [without welcome and kernel messages]"
-pkgver=2.04
-pkgrel=5
+pkgver=2.06
+pkgrel=1
url="https://www.gnu.org/software/grub/"
arch=('x86_64' 'i686')
license=('GPL3')
@@ -61,10 +61,9 @@ source=("https://ftp.gnu.org/gnu/${pkgname%-*}/${pkgname%-*}-${pkgver}.tar.xz"
'05-sleep_shift.patch'
'06-maybe_quiet.patch'
'07-quick_boot.patch'
- '08-fix_wrong_image_size.patch'
'grub.silent')
-sha256sums=('e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d'
+sha256sums=('b79ea44af91b93d17cd3fe80bdae6ed43770678a9a5ae192ccea803ebb657ee1'
'fb6b37db9b14fd03e4d26775d84b570fbe91d4ea5de3df4e31114d79a2dfa97e'
'd101e9d33fbc67f7aaf6fb1191ec1315e8e5572c1d0538b95746ee194b8860db'
'b6e1c57dc9632ddf14e0acd96c5182cb4491994b67765cb11518d1356b603879'
@@ -73,7 +72,6 @@ sha256sums=('e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d'
'4b189e00a8c97ec09903e9588e02fc78b4bb114ee4822fcce13811aca00c8884'
'b7489c7facc4fb3dad4426c9c00079b64908640a2bec2409e22194daa3f72af4'
'1723340737b91a5bf503829bbe66b1c56683ef0e533f20d18b7098840aecb3a2'
- '13053d6f36456234a5ed7dc4d4006459f6f9d2c9a19e6febfa4dc17cb5982bd3'
'4f2e9d585b7b0ef8ce0d09e88391d1397b50883c7cb1516dc99785934abe15a2')
prepare() {
@@ -108,8 +106,6 @@ prepare() {
patch -Np1 -i "${srcdir}/07-quick_boot.patch"
echo
- msg "Appliying patch to fix wrong image size on some rare cases"
- patch -Np1 -i "${srcdir}/08-fix_wrong_image_size.patch"
echo
msg "Pull in latest language files"