summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluspi2024-04-04 15:30:27 -0500
committerluspi2024-04-04 15:30:27 -0500
commita63de357ce5f50429aa211a5a022071987de38bc (patch)
tree1dd7dc4a69a94d8b13b659e8d23f44e3e70bde21
parent4159770b0223daefa539d59c47355f24b982a170 (diff)
downloadaur-a63de357ce5f50429aa211a5a022071987de38bc.tar.gz
update to 4.4
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD17
-rw-r--r--magick.patch27
3 files changed, 12 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80d64e71ee8a..fe1bf2154cba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = photoqt
pkgdesc = Fast and highly configurable image viewer with a simple and nice interface.
- pkgver = 4.3
- pkgrel = 3
+ pkgver = 4.4
+ pkgrel = 1
url = http://photoqt.org/
arch = x86_64
license = GPL2
@@ -26,12 +26,10 @@ pkgbase = photoqt
depends = python-pychromecast
depends = qt6-webengine
depends = zxing-cpp
+ depends = lcms2
optdepends = libqpsd-git: PSB/PSD support
optdepends = xcftools: XCF support
- optdepends = poppler-qt6: PDF support
- source = https://photoqt.org/downloads/source/photoqt-4.3.tar.gz
- source = magick.patch
- sha256sums = 07466e6ef5881191670f6bfbe1ba4fbfeff0afbbda1d2f503f8ffff7f69f8f34
- sha256sums = a757cf48c09102de01071841af1d154e20826f9b00665d45c1bb4132e789390f
+ source = https://photoqt.org/downloads/source/photoqt-4.4.tar.gz
+ sha256sums = b789f6736f1fe17da3bd6864c1586d9b2ce412e37563e0e8c9f44ba9540f0876
pkgname = photoqt
diff --git a/PKGBUILD b/PKGBUILD
index bb5c860af003..a42f924de836 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,18 @@
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
pkgname=photoqt
-pkgver=4.3
-pkgrel=3
+pkgver=4.4
+pkgrel=1
pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
arch=('x86_64')
url="http://photoqt.org/"
license=('GPL2')
-depends=('exiv2' 'imagemagick' 'qt6-imageformats' 'qt6-multimedia' 'qt6-svg' 'qt6-declarative' 'qt6-location' 'qt6-positioning' 'libraw' 'hicolor-icon-theme' 'libarchive' 'kimageformats' 'pugixml' 'mpv' 'resvg' 'python-pychromecast' 'qt6-webengine' 'zxing-cpp')
+depends=('exiv2' 'imagemagick' 'qt6-imageformats' 'qt6-multimedia' 'qt6-svg' 'qt6-declarative' 'qt6-location' 'qt6-positioning' 'libraw' 'hicolor-icon-theme' 'libarchive' 'kimageformats' 'pugixml' 'mpv' 'resvg' 'python-pychromecast' 'qt6-webengine' 'zxing-cpp' 'lcms2')
optdepends=('libqpsd-git: PSB/PSD support'
- 'xcftools: XCF support'
- 'poppler-qt6: PDF support')
+ 'xcftools: XCF support')
makedepends=('cmake' 'qt6-tools' 'extra-cmake-modules')
-source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz
- magick.patch)
-sha256sums=('07466e6ef5881191670f6bfbe1ba4fbfeff0afbbda1d2f503f8ffff7f69f8f34'
- 'a757cf48c09102de01071841af1d154e20826f9b00665d45c1bb4132e789390f')
+source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz)
+sha256sums=('b789f6736f1fe17da3bd6864c1586d9b2ce412e37563e0e8c9f44ba9540f0876')
# NOTE
# To use GraphicsMagick instead of ImageMagick replace it in the depends array above and change
@@ -35,7 +32,7 @@ prepare() {
patch -p1 < $srcdir/magick.patch
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DQTPDF=ON -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF -DLIBVIPS=OFF -DVIDEO_MPV=ON -DCHROMECAST=ON -DRESVG=ON -DZXING=ON -DCMAKE_BUILD_TYPE=Release
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DQTPDF=ON -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF -DLIBVIPS=OFF -DVIDEO_MPV=ON -DCHROMECAST=ON -DRESVG=ON -DZXING=ON -DLCMS2=ON -DCMAKE_BUILD_TYPE=Release
}
diff --git a/magick.patch b/magick.patch
deleted file mode 100644
index d938b62e16b7..000000000000
--- a/magick.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/CMakeLists.txt 2024-02-29 19:00:00.000000000 -0600
-+++ b/CMakeLists.txt 2024-03-05 15:40:11.585633947 -0600
-@@ -85,6 +85,7 @@
-
- if(IMAGEMAGICK)
- find_package(ImageMagick COMPONENTS Magick++)
-+ string(REPLACE "libMagick++-6." "libMagick++-7." ImageMagick_Magick++_LIBRARY "${ImageMagick_Magick++_LIBRARY}")
- if(GRAPHICSMAGICK)
- set(GRAPHICSMAGICK OFF)
- message("** ImageMagick and GraphicsMagick cannot be used at the same time.")
-@@ -455,13 +456,13 @@
- message(FATAL_ERROR "** Unable to locate ImageMagick... is it installed?")
- else()
- message("** Using ImageMagick")
-- include_directories(${ImageMagick_INCLUDE_DIRS})
-+ include_directories("${ImageMagick_Magick++_INCLUDE_DIR}")
- add_definitions(-DPQMIMAGEMAGICK)
- add_definitions(-DMAGICKCORE_QUANTUM_DEPTH=16)
- add_definitions(-DMAGICKCORE_HDRI_ENABLE=1)
-- target_link_libraries(photoqt PRIVATE ${ImageMagick_LIBRARIES})
-+ target_link_libraries(photoqt PRIVATE "${ImageMagick_Magick++_LIBRARY}")
- if(TESTING)
-- target_link_libraries(photoqt_test PRIVATE ${ImageMagick_LIBRARIES})
-+ target_link_libraries(photoqt_test PRIVATE "${ImageMagick_Magick++_LIBRARY}")
- endif()
- endif()
- else()