summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:16 +0200
committerMuflone2015-06-13 17:59:16 +0200
commita646e0b896c9a5cfed3cb932a88eca262802b5ed (patch)
tree224733724d79be6a3ca199bb58afb6dea9701d95
downloadaur-a646e0b896c9a5cfed3cb932a88eca262802b5ed.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD34
-rw-r--r--cuttlefish.install8
-rw-r--r--desktop-autostart.patch19
-rw-r--r--plugins-use-site-packages.patch12
5 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b06948a9782f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = cuttlefish
+ pkgdesc = Adapt your computer's appearance and settings according to the environment.
+ pkgver = 12.08
+ pkgrel = 6
+ url = https://launchpad.net/cuttlefish
+ install = cuttlefish.install
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-distutils-extra
+ depends = python2-psutil
+ depends = python2-udev
+ depends = python2-gobject
+ depends = python2-xdg
+ depends = gnome-menus
+ depends = libwnck3
+ depends = dconf
+ source = https://launchpad.net/cuttlefish/trunk/12.08/+download/cuttlefish_12.08.tar.gz
+ source = plugins-use-site-packages.patch
+ source = desktop-autostart.patch
+ md5sums = 400e8caa17036c1aa5a0fda570241c05
+ md5sums = 3379bb17d3e36e37b9bc7ea3d2fb0e0c
+ md5sums = ed2b506ac114bab485b71d664fdcfdd3
+ sha1sums = 58372fdc4a91a5a3fd8aa4a933460a46a72a8bb7
+ sha1sums = 8033ec7c0e5fabdbad6f8364e52cf60499e0f5ab
+ sha1sums = e17e6ec055a9dd676596dd4bd61d48adbc2ca98a
+ sha256sums = e53702fe841ddddaa74a7b02dca7d6edf1fd314ccac831bfd6d1b235ed4c57b0
+ sha256sums = 3d6e2db4d085fd014ffcb5cee22ab2125bc1f77c7cb4cb50aa8e06fcd195ef3c
+ sha256sums = d764d78d59a5789f422eed77fd6b34b1bdc981d4e0c5afa0148b2e16ee276c39
+
+pkgname = cuttlefish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfd93ae93b49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=cuttlefish
+pkgver=12.08
+pkgrel=6
+pkgdesc="Adapt your computer's appearance and settings according to the environment."
+arch=('any')
+url="https://launchpad.net/cuttlefish"
+license=('GPL')
+depends=('python2' 'python2-distutils-extra' 'python2-psutil' 'python2-udev' 'python2-gobject' 'python2-xdg' 'gnome-menus' 'libwnck3' 'dconf')
+install='cuttlefish.install'
+source=("https://launchpad.net/cuttlefish/trunk/${pkgver}/+download/cuttlefish_${pkgver}.tar.gz"
+ 'plugins-use-site-packages.patch'
+ 'desktop-autostart.patch')
+md5sums=('400e8caa17036c1aa5a0fda570241c05'
+ '3379bb17d3e36e37b9bc7ea3d2fb0e0c'
+ 'ed2b506ac114bab485b71d664fdcfdd3')
+sha1sums=('58372fdc4a91a5a3fd8aa4a933460a46a72a8bb7'
+ '8033ec7c0e5fabdbad6f8364e52cf60499e0f5ab'
+ 'e17e6ec055a9dd676596dd4bd61d48adbc2ca98a')
+sha256sums=('e53702fe841ddddaa74a7b02dca7d6edf1fd314ccac831bfd6d1b235ed4c57b0'
+ '3d6e2db4d085fd014ffcb5cee22ab2125bc1f77c7cb4cb50aa8e06fcd195ef3c'
+ 'd764d78d59a5789f422eed77fd6b34b1bdc981d4e0c5afa0148b2e16ee276c39')
+
+prepare() {
+ patch -p0 -i "plugins-use-site-packages.patch"
+ patch -p0 -i "desktop-autostart.patch"
+}
+
+package() {
+ cd "${pkgname}"
+ glib-compile-schemas "data/glib-2.0/schemas"
+ GSETTINGS_SCHEMA_DIR="data/glib-2.0/schemas" python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
diff --git a/cuttlefish.install b/cuttlefish.install
new file mode 100644
index 000000000000..e068dedc93d0
--- /dev/null
+++ b/cuttlefish.install
@@ -0,0 +1,8 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_remove() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
diff --git a/desktop-autostart.patch b/desktop-autostart.patch
new file mode 100644
index 000000000000..d708a5f8b458
--- /dev/null
+++ b/desktop-autostart.patch
@@ -0,0 +1,19 @@
+diff -aur cuttlefish.orig/cuttlefish/PreferencesCuttlefishDialog.py cuttlefish/cuttlefish/PreferencesCuttlefishDialog.py
+--- cuttlefish.orig/cuttlefish/PreferencesCuttlefishDialog.py 2012-08-25 10:22:17.000000000 +0000
++++ cuttlefish/cuttlefish/PreferencesCuttlefishDialog.py 2012-10-06 12:44:08.988824119 +0000
+@@ -70,13 +70,13 @@
+ else:
+ self._autostart.add_section('Desktop Entry', )
+ self._autostart.set('Desktop Entry', 'Type', 'Application')
+- self._autostart.set('Desktop Entry', 'Exec', '/opt/extras.ubuntu.com/cuttlefish/bin/cuttlefish --hidden')
++ self._autostart.set('Desktop Entry', 'Exec', '/usr/bin/cuttlefish --hidden')
+ self._autostart.set('Desktop Entry', 'Hidden', 'false')
+ self._autostart.set('Desktop Entry', 'NoDisplay', 'false')
+ self._autostart.set('Desktop Entry', 'X-GNOME-Autostart-enabled', 'false')
+ self._autostart.set('Desktop Entry', 'Name', 'Cuttlefish')
+ self._autostart.set('Desktop Entry', 'Categories', 'GNOME;Utility;')
+- self._autostart.set('Desktop Entry', 'Icon', '/opt/extras.ubuntu.com/cuttlefish/share/cuttlefish/media/tentacle.svg')
++ self._autostart.set('Desktop Entry', 'Icon', '/usr/share/cuttlefish/media/tentacle.svg')
+ self._autostart.set('Desktop Entry', 'Comment', 'Cuttlefish Autostart Entry')
+
+ self.ui.togAutostart.set_active(self._autostart.getboolean('Desktop Entry', 'X-GNOME-Autostart-enabled'))
diff --git a/plugins-use-site-packages.patch b/plugins-use-site-packages.patch
new file mode 100644
index 000000000000..222cbeb82f9d
--- /dev/null
+++ b/plugins-use-site-packages.patch
@@ -0,0 +1,12 @@
+diff -aur cuttlefish.orig/cuttlefish/plugins/__init__.py cuttlefish/cuttlefish/plugins/__init__.py
+--- cuttlefish.orig/cuttlefish/plugins/__init__.py 2012-09-04 22:07:11.514881399 +0000
++++ cuttlefish/cuttlefish/plugins/__init__.py 2012-09-04 22:07:28.604881274 +0000
+@@ -50,7 +50,7 @@
+
+ self.__add_dir('cuttlefish.plugins.user', '~/.cuttlefish/plugins')
+ self.__add_dir('cuttlefish.plugins.default', '/opt/extras.ubuntu.com/cuttlefish/cuttlefish/plugins')
+- self.__add_dir('cuttlefish.plugins.altdefault', '/usr/lib/python2.7/dist-packages/cuttlefish/plugins')
++ self.__add_dir('cuttlefish.plugins.altdefault', '/usr/lib/python2.7/site-packages/cuttlefish/plugins')
+
+ def __add_dir(self, modid, dir):
+ dir = os.path.abspath(os.path.expandvars(os.path.expanduser(dir)))