summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692023-02-27 21:59:05 +0100
committerarchibald8692023-02-27 21:59:05 +0100
commita688537ac45316d2036db722183b3d4fcd77d04a (patch)
tree8a6b5931bc2fcf9d1b5f4181ce0702fa5b3c7f09
parent5d1d8b78cf65f0a304b1b279b05361742cfa8cef (diff)
downloadaur-a688537ac45316d2036db722183b3d4fcd77d04a.tar.gz
Fix build
- check out package's version tag of LLVM and Clang repos instead of patches branch - switch to Ninja as build system - update Python dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8ea63190cc7..61c2b89de71a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = cling
pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
pkgver = 0.9
- pkgrel = 3
+ pkgrel = 4
url = https://root.cern.ch/cling
arch = i686
arch = x86_64
license = custom:Cling Release License
makedepends = git
makedepends = cmake
- makedepends = python2
+ makedepends = ninja
+ makedepends = python
depends = libxml2
- optdepends = python2: support for scan-view and Jupyter
optdepends = perl: support for scan-build, ccc-analyzer and c++-analyzer
+ optdepends = python: support for scan-view and Jupyter
+ optdepends = python-pygments: support for opt-viewer
+ optdepends = python-yaml: support for opt-viewer
provides = cling
conflicts = cling
- source = llvm::git+http://root.cern/git/llvm.git#branch=cling-patches
- source = clang::git+http://root.cern/git/clang.git#branch=cling-patches
+ source = llvm::git+http://root.cern/git/llvm.git#tag=cling-v0.9
+ source = clang::git+http://root.cern/git/clang.git#tag=cling-v0.9
source = cling::git+http://root.cern/git/cling.git#tag=v0.9
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 6ab777fff14d..251fe19c2d3e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
/pkg/
/src/
*.tar.xz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index add937ea679a..1115dca3ec6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cling
pkgver=0.9
-pkgrel=3
+pkgrel=4
pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
arch=("i686" "x86_64")
url="https://root.cern.ch/cling"
@@ -10,14 +10,16 @@ license=("custom:Cling Release License")
provides=("cling")
conflicts=("cling")
depends=("libxml2")
-makedepends=("git" "cmake" "python2")
+makedepends=("git" "cmake" "ninja" "python")
optdepends=(
- "python2: support for scan-view and Jupyter"
"perl: support for scan-build, ccc-analyzer and c++-analyzer"
+ "python: support for scan-view and Jupyter"
+ "python-pygments: support for opt-viewer"
+ "python-yaml: support for opt-viewer"
)
source=(
- "llvm::git+http://root.cern/git/llvm.git#branch=cling-patches"
- "clang::git+http://root.cern/git/clang.git#branch=cling-patches"
+ "llvm::git+http://root.cern/git/llvm.git#tag=cling-v$pkgver"
+ "clang::git+http://root.cern/git/clang.git#tag=cling-v$pkgver"
"cling::git+http://root.cern/git/cling.git#tag=v$pkgver"
)
sha256sums=(
@@ -46,6 +48,7 @@ build() {
cd "$srcdir/build"
cmake \
+ -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/opt/cling" \
-DLLVM_TARGETS_TO_BUILD="host;NVPTX" \
@@ -59,14 +62,14 @@ build() {
-DFFI_INCLUDE_DIR=$(pkg-config --cflags-only-I libffi | cut -c3-) \
"$srcdir/llvm"
- make -C tools/clang
- make -C tools/cling
+ ninja clang
+ ninja cling
}
package() {
cd "$srcdir/build"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja install
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"