summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2023-11-07 00:13:44 +0200
committerEvert Vorster2023-11-07 00:13:44 +0200
commita6ca6e9a45f35c4dc578f7ccd94261d113416e4f (patch)
tree326641bd3926d4742545995dc17e467aef781ecf
parent6fcd636290b8cfa6da6f2c5c065a20330cfa0bfe (diff)
downloadaur-a6ca6e9a45f35c4dc578f7ccd94261d113416e4f.tar.gz
Fixing build issue, and update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD49
2 files changed, 32 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c08e4d9ec2b3..cc100f353733 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
-pkgbase = audacity-qt-git
- pkgdesc = Record and edit audio files - Built with package versions as recommended by Audacity team
- pkgver = 3.4.0.0.r17467
+pkgbase = audacity-local-git
+ pkgdesc = Record and edit audio files - Built with mostly system libraries, except for xwWidgets and PortMidi, and following the qt branch.
+ pkgver = 3.5.0.0.r18112
pkgrel = 1
url = https://audacityteam.org
arch = x86_64
groups = pro-audio
license = GPL2
license = CCPL
+ makedepends = opusfile
+ makedepends = xcb-util-keysyms
+ makedepends = xcb-util
makedepends = cmake
makedepends = autoconf
makedepends = automake
@@ -19,7 +22,6 @@ pkgbase = audacity-qt-git
depends = ffmpeg
depends = portmidi
depends = python
- depends = vst3sdk
depends = portaudio
depends = jack
provides = audacity
@@ -29,7 +31,7 @@ pkgbase = audacity-qt-git
provides = vst-host
provides = vst3-host
conflicts = audacity
- source = git+https://github.com/audacity/audacity.git#branch=qt
+ source = git+https://github.com/audacity/audacity.git
sha512sums = SKIP
-pkgname = audacity-qt-git
+pkgname = audacity-local-git
diff --git a/PKGBUILD b/PKGBUILD
index 071277a6224c..0a3872ca600c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: evorster <evorster@gmail.com>
# Contributor: osch <oliver@luced.de>
-pkgname=audacity-qt-git
-pkgver=3.4.0.0.r17467
+pkgname=audacity-local-git
+pkgver=3.5.0.0.r18112
pkgrel=1
-pkgdesc="Record and edit audio files - Built with package versions as recommended by Audacity team"
+pkgdesc="Record and edit audio files - Built with mostly system libraries, except for xwWidgets and PortMidi, and following the qt branch."
arch=('x86_64')
url="https://audacityteam.org"
license=('GPL2' 'CCPL')
groups=('pro-audio')
-depends=('gtk3' 'gtk2' 'ffmpeg' 'portmidi' 'python' 'vst3sdk'
+depends=('gtk3' 'gtk2' 'ffmpeg' 'portmidi' 'python'
'portaudio' 'jack')
-makedepends=('cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan' 'catch2')
+makedepends=('opusfile' 'xcb-util-keysyms' 'xcb-util' 'cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan' 'catch2')
provides=(
audacity
ladspa-host
@@ -22,10 +22,10 @@ provides=(
)
conflicts=("audacity")
#
-source=("git+https://github.com/audacity/audacity.git#branch=qt")
+source=("git+https://github.com/audacity/audacity.git")
## Comment out the source variable above and uncomment the one below for the last version where the calf plugins work properly
# There is some sort of regression in later versions. Once it's sorted I'll remove this comment.
-#source=("git+https://github.com/audacity/audacity.git#branch=release-3.1.3")
+#source=("git+https://github.com/audacity/audacity.git#branch=qt")
#
sha512sums=('SKIP')
@@ -47,36 +47,35 @@ prepare() {
cd build
depsDir=$(readlink -f ./.offline)
-## To set a custom download directory for Conan2 still seems a bit of a mystery to me.
export CONAN_USER_HOME="$depsDir/conan"
-# conan config home
-# conan config init
-# conan config set storage.download_cache="$CONAN_USER_HOME/download_cache"
-#Let's not remove it every time, it's a pain building them.
-# conan remove "*" --src --builds --force
+
cmake -G "Unix Makefiles" ../audacity \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DAUDACITY_BUILD_LEVEL=2 \
+ -Daudacity_has_vst3=off \
+ -Daudacity_use_jpeg=system \
+ -Daudacity_has_networking=off \
+ -Daudacity_lib_preference=system \
+ -Daudacity_use_expat=system \
-Daudacity_use_ffmpeg=loaded \
- -Daudacity_use_vst3sdk=system
-# -Daudacity_has_vst3=Off \
-# -DAUDACITY_BUILD_LEVEL=2 \
-# -Daudacity_has_networking=off \
-# -Daudacity_lib_preference=system local \
-# -Daudacity_use_expat=system \
-# -Daudacity_use_zlib=system \
-# -Daudacity_use_curl=system \
-# -Daudacity_use_portmidi=local \
-# -Daudacity_use_wxwidgets=local \
+ -Daudacity_use_zlib=system \
+ -Daudacity_use_curl=system \
+ -Daudacity_use_midi=local \
+ -Daudacity_use_wxwidgets=local
+
+
+# Old build options....
+# -Daudacity_use_portaudio=local \
+# -Daudacity_use_ffmpeg=loaded
+# -Daudacity_use_vst3sdk=system
}
build() {
cd build
make
-#Let's not remove the conan stuff every time, rebuilding's a pain.
-# conan remove "*" --src --builds --force
}
package() {