summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatrix2022-05-11 19:18:42 +0100
committerMatrix2022-05-11 19:18:42 +0100
commita6d029be767dcb046561b0e882a05418b6215dce (patch)
tree7612a8e39fd3d17a5319b4ba07d805ee3920fab1
parent6b0ebbe6a8c799331359b0734006cfd6d4e8132d (diff)
downloadaur-a6d029be767dcb046561b0e882a05418b6215dce.tar.gz
better version + changed some stuff
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--gnome-shell-extension.install10
3 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4edf05b32f23..32459b20fd5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = gnome-shell-extension-datetime-format-git
pkgdesc = Gnome extension which allows users to customise the datetime format on the status bar and date menu.
- pkgver = r5.f660b1e
+ pkgver = r13.556b1b9
pkgrel = 1
- url = https://github.com/Daniel-Khodabakhsh/datetime-format
+ url = https://github.com/nvlgit/datetime-format
install = gnome-shell-extension.install
arch = any
license = GPL3
makedepends = git
makedepends = nodejs
- depends = gnome-shell>=3.20
- source = git+https://github.com/Daniel-Khodabakhsh/datetime-format.git
+ depends = gnome-shell>=1:40
+ source = git+https://github.com/nvlgit/datetime-format.git
source = build.patch
sha256sums = SKIP
sha256sums = ca11b183e163eb143ea3a7ae937df07bd9759ff141764ac09117364cff8fc10d
diff --git a/PKGBUILD b/PKGBUILD
index 5d8cba7c3fd8..0d17c30cde52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: <thysupremematrix@tuta.io>
pkgname=gnome-shell-extension-datetime-format-git
-pkgver=r5.f660b1e
+pkgver=r13.556b1b9
pkgrel=1
pkgdesc="Gnome extension which allows users to customise the datetime format on the status bar and date menu."
arch=(any)
-url="https://github.com/Daniel-Khodabakhsh/datetime-format"
+url="https://github.com/nvlgit/datetime-format"
license=("GPL3")
-depends=('gnome-shell>=3.20')
+depends=('gnome-shell>=1:40')
makedepends=('git' 'nodejs')
-source=("git+https://github.com/Daniel-Khodabakhsh/datetime-format.git" "build.patch")
+source=("git+https://github.com/nvlgit/datetime-format.git" "build.patch")
install="gnome-shell-extension.install"
sha256sums=('SKIP'
'ca11b183e163eb143ea3a7ae937df07bd9759ff141764ac09117364cff8fc10d')
@@ -22,7 +22,10 @@ prepare(){
pkgver() {
cd $srcdir/${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
index 3488506f6ca0..01faca69e344 100644
--- a/gnome-shell-extension.install
+++ b/gnome-shell-extension.install
@@ -1,9 +1,9 @@
post_install() {
- echo " ______________________________________________________ "
- echo "==> / \"
- echo "==> | Don't forget to Restart GNOME Shell |"
- echo "==> | (Alt+F2, type r) |"
- echo " \______________________________________________________/"
+ echo " ______________________________________________________ "
+ echo " ==> / \\"
+ echo " ==> / Don't forget to Restart GNOME Shell \\"
+ echo " ==> \ (Alt+F2, type r) /"
+ echo " \______________________________________________________/"
}
post_upgrade() {