summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2017-02-27 17:41:28 -0500
committergraysky2017-02-27 17:41:28 -0500
commita6dcfb51b5513ea273897030194e0ef591487ce3 (patch)
tree9dd06fc61a269f1e862fb0c54357186ae7c7cfd2
parentc4325fb3e553eb5683e965cc2205916a99c4f465 (diff)
downloadaur-a6dcfb51b5513ea273897030194e0ef591487ce3.tar.gz
Update to 6.30.223.271-38
-rw-r--r--.SRCINFO20
-rw-r--r--001-null-pointer-fix.patch27
-rw-r--r--002-rdtscl.patch18
-rw-r--r--PKGBUILD48
-rw-r--r--linux47.patch (renamed from 003-linux47.patch)0
-rw-r--r--readme.install2
-rw-r--r--wl_linux.c.patch14
7 files changed, 45 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2046cd436d9a..6489bcd3418a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
# Generated by mksrcinfo v8
-# Tue Feb 21 20:20:16 UTC 2017
+# Mon Feb 27 22:41:28 UTC 2017
pkgbase = broadcom-wl-ck
pkgdesc = Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.
pkgver = 6.30.223.271
- pkgrel = 37
+ pkgrel = 38
url = https://www.broadcom.com/support/802.11
install = readme.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-ck-headers>=4.9
- makedepends = linux-ck-headers<4.10
- depends = linux-ck>=4.8
- depends = linux-ck<4.10
+ makedepends = linux-ck-headers>=4.10
+ makedepends = linux-ck-headers<4.11
+ depends = linux-ck>=4.10
+ depends = linux-ck<4.11
source = modprobe.d
source = license.patch
- source = 001-null-pointer-fix.patch
- source = 002-rdtscl.patch
- source = 003-linux47.patch
+ source = wl_linux.c.patch
+ source = linux47.patch
source = linux48.patch
sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
sha256sums = 2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac
- sha256sums = 32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f
- sha256sums = 29929989d86fde903f98419ce52dbb1d862cd4a11b0b13b2432886eeb6daabea
+ sha256sums = 583335a6edb2ed1094977c401643d3e60471c6bc5c3ea81f45910a9cccb06032
sha256sums = 30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e
sha256sums = 833af3b209d6a101d9094db16480bda2ad9a85797059b0ae0b13235ad3818e9c
source_i686 = https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35-nodebug-pcoem-6_30_223_271.tar.gz
diff --git a/001-null-pointer-fix.patch b/001-null-pointer-fix.patch
deleted file mode 100644
index adef19f30af1..000000000000
--- a/001-null-pointer-fix.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Description: Fixing null pointer crash
-
-Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773713
-Bug-Ubuntu: https://launchpad.net/bugs/1415880
-Last-Update: 2015-08-18
-
----
- src/wl/sys/wl_linux.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
-index 860b935..295156f 100644
---- a/src/wl/sys/wl_linux.c
-+++ b/src/wl/sys/wl_linux.c
-@@ -2157,8 +2157,8 @@ wl_start(struct sk_buff *skb, struct net_device *dev)
- wlif = WL_DEV_IF(dev);
- wl = WL_INFO(dev);
-
-+ skb->prev = NULL;
- if (WL_ALL_PASSIVE_ENAB(wl) || (WL_RTR() && WL_CONFIG_SMP())) {
-- skb->prev = NULL;
-
- TXQ_LOCK(wl);
-
---
-1.9.1
-
diff --git a/002-rdtscl.patch b/002-rdtscl.patch
deleted file mode 100644
index cfa16075409b..000000000000
--- a/002-rdtscl.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=fe47ae6e1a5005b2e82f7eab57b5c3820453293a
-https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=4ea1636b04dbd66536fa387bae2eea463efc705b
-
-diff -ru a/src/shared/linux_osl.c b/src/shared/linux_osl.c
---- a/src/shared/linux_osl.c 2015-09-19 01:47:15.000000000 +0300
-+++ b/src/shared/linux_osl.c 2015-11-21 15:20:30.585902518 +0200
-@@ -932,7 +932,11 @@
- uint cycles;
-
- #if defined(__i386__)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 3, 0)
-+ cycles = (u32)rdtsc();
-+#else
- rdtscl(cycles);
-+#endif
- #else
- cycles = 0;
- #endif
diff --git a/PKGBUILD b/PKGBUILD
index 52e254b5c8db..830bf522a8da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,33 @@
# Maintainer: graysky <graysky AT archlinux DOT org>
-# Maintainer: Armin K. <krejzi at email dot com>
+# Contributor: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: Armin K. <krejzi at email dot com>
# Contributor: Austin ( doorknob60 [at] gmail [dot] com )
# Contributor: Gaetan Bisson <bisson@archlinux.org>
-# Contributor: USA-RedDragon (AUR)
pkgname=broadcom-wl-ck
pkgver=6.30.223.271
-pkgrel=37
+pkgrel=38
_pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.'
-_extramodules="extramodules-4.9-ck"
+_extramodules="extramodules-4.10-ck"
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
pkgdesc="${_pkgdesc}"
arch=('i686' 'x86_64')
url='https://www.broadcom.com/support/802.11'
license=('custom')
-depends=('linux-ck>=4.8' 'linux-ck<4.10')
-makedepends=('linux-ck-headers>=4.9' 'linux-ck-headers<4.10')
+depends=('linux-ck>=4.10' 'linux-ck<4.11')
+makedepends=('linux-ck-headers>=4.10' 'linux-ck-headers<4.11')
#replaces=()
#groups=('ck-generic')
source=('modprobe.d'
'license.patch'
-'001-null-pointer-fix.patch'
-'002-rdtscl.patch'
-'003-linux47.patch'
+'wl_linux.c.patch'
+'linux47.patch'
'linux48.patch')
-source_i686+=("https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
-source_x86_64+=("http://www.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-${pkgver//./_}.tar.gz")
+source_i686=("https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
+source_x86_64=("http://www.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-${pkgver//./_}.tar.gz")
sha256sums=('b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32'
'2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac'
- '32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f'
- '29929989d86fde903f98419ce52dbb1d862cd4a11b0b13b2432886eeb6daabea'
+ '583335a6edb2ed1094977c401643d3e60471c6bc5c3ea81f45910a9cccb06032'
'30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e'
'833af3b209d6a101d9094db16480bda2ad9a85797059b0ae0b13235ad3818e9c')
sha256sums_i686=('4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd')
@@ -39,26 +37,22 @@ install=readme.install
prepare() {
patch -p1 -i license.patch
- patch -p1 -i 001-null-pointer-fix.patch
- patch -p1 -i 003-linux47.patch
- patch -p1 -i linux48.patch
-
- sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" -i src/wl/sys/wl_linux.c
-
- # linux 4.3 on i686 needs this to build
- [[ $CARCH = "i686" ]] && patch -p1 -i 002-rdtscl.patch || return 0
+ patch -p1 -i wl_linux.c.patch
+ patch -p1 -i linux47.patch
+ patch -p1 -i linux48.patch
+ sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" -i src/wl/sys/wl_linux.c
}
build() {
- make -C /usr/lib/modules/"${_kernver}"/build M=`pwd`
+ make -C /usr/lib/modules/"${_kernver}"/build M=`pwd`
}
package() {
- install -Dm644 wl.ko "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
+ install -Dm644 wl.ko "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
- # makepkg does not do this automatically for this pkg so do it here
- gzip -9 "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
- install -Dm644 lib/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 modprobe.d "${pkgdir}/usr/lib/modprobe.d/broadcom-wl_ck.conf"
+ # makepkg does not do this automatically for this pkg so do it here
+ gzip -9 "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
+ install -Dm644 lib/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 modprobe.d "${pkgdir}/usr/lib/modprobe.d/broadcom-wl_ck.conf"
}
diff --git a/003-linux47.patch b/linux47.patch
index 566680a09140..566680a09140 100644
--- a/003-linux47.patch
+++ b/linux47.patch
diff --git a/readme.install b/readme.install
index d8777449dc60..9ce7bf2307b5 100644
--- a/readme.install
+++ b/readme.install
@@ -1,5 +1,5 @@
post_upgrade() {
- EXTRAMODULES='extramodules-4.9-ck'
+ EXTRAMODULES='extramodules-4.10-ck'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}
diff --git a/wl_linux.c.patch b/wl_linux.c.patch
new file mode 100644
index 000000000000..cf7d4b44ead3
--- /dev/null
+++ b/wl_linux.c.patch
@@ -0,0 +1,14 @@
+diff --git a/src/wl/sys/wl_linux.c.orig b/src/wl/sys/wl_linux.c
+index eb00717..489c9f5 100644
+--- a/src/wl/sys/wl_linux.c.orig
++++ b/src/wl/sys/wl_linux.c
+@@ -2166,8 +2166,8 @@ wl_start(struct sk_buff *skb, struct net_device *dev)
+ wlif = WL_DEV_IF(dev);
+ wl = WL_INFO(dev);
+
++ skb->prev = NULL;
+ if (WL_ALL_PASSIVE_ENAB(wl) || (WL_RTR() && WL_CONFIG_SMP())) {
+- skb->prev = NULL;
+
+ TXQ_LOCK(wl);
+