summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCian Mc Govern2020-11-20 21:27:43 +0000
committerCian Mc Govern2020-11-20 21:27:43 +0000
commita6f9253285a2f3d53adc961669b6cc46bba71d9f (patch)
treec737589002d167a490b3c7e740da01203b2ad5a3
parentddff5761a00f5ce61c253b4ee7042c53ba01facf (diff)
downloadaur-a6f9253285a2f3d53adc961669b6cc46bba71d9f.tar.gz
Fix building with bison 3.7
QTBUG-86018 https://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?h=80-based&id=1a53f599
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--QTBUG-86018.patch37
3 files changed, 46 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67235e162861..cb483d146420 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-webengine-595
pkgdesc = Provides support for web applications using the Chromium browser project (v5.9.5)
pkgver = 5.9.5
- pkgrel = 2
+ pkgrel = 3
url = http://qt-project.org/
arch = i686
arch = x86_64
@@ -36,6 +36,7 @@ pkgbase = qt5-webengine-595
source = WEBRTC-7857.diff
source = qtwebengine-ffmpeg4.patch
source = fix-building-with-system-icu.diff
+ source = QTBUG-86018.patch
sha256sums = 70d26db4e7944291c5f843b875916fb95ceec0f0a8fea3daea8004990199fc07
sha256sums = ae6b783f6dc8a6b6b97e44101a685aeca858bd5948e083ce442821b5d8db8c74
sha256sums = 3510f53302c6147882f43855da448b4f08cbdb10297b91474849ddbd359d5e9d
@@ -43,6 +44,7 @@ pkgbase = qt5-webengine-595
sha256sums = ddd8d8b64fb2f81bbc5acd3d77cc6aeb79df44db451c3fed94f0e05b73c7b078
sha256sums = 0be352f23946a41cddae941ecedfe1bceb62b23e2a1225dd5469e77e251ccf42
sha256sums = cef22eeef1dedd484dec4cf94bb0aed2881ea7b2ee6d563e6940f4362e26604f
+ sha256sums = 7849a944b63fbdcab3e15bce6158fa74d213f4f61bce7e870f05060fa00e2638
pkgname = qt5-webengine-595
diff --git a/PKGBUILD b/PKGBUILD
index 28d6916d7541..95abe84e57fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=qt5-webengine-595
_qtver=5.9.5
pkgver=${_qtver/-/}
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('LGPL3' 'LGPL2.1' 'BSD')
@@ -21,14 +21,16 @@ source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submo
"QTBUG-77037.diff"
"WEBRTC-7857.diff"
"qtwebengine-ffmpeg4.patch"
- "fix-building-with-system-icu.diff")
+ "fix-building-with-system-icu.diff"
+ "QTBUG-86018.patch")
sha256sums=('70d26db4e7944291c5f843b875916fb95ceec0f0a8fea3daea8004990199fc07'
'ae6b783f6dc8a6b6b97e44101a685aeca858bd5948e083ce442821b5d8db8c74'
'3510f53302c6147882f43855da448b4f08cbdb10297b91474849ddbd359d5e9d'
'5f1b988568f57bff1b64341d0a447d1e43189215a7c0689540f45bedcf969119'
'ddd8d8b64fb2f81bbc5acd3d77cc6aeb79df44db451c3fed94f0e05b73c7b078'
'0be352f23946a41cddae941ecedfe1bceb62b23e2a1225dd5469e77e251ccf42'
- 'cef22eeef1dedd484dec4cf94bb0aed2881ea7b2ee6d563e6940f4362e26604f')
+ 'cef22eeef1dedd484dec4cf94bb0aed2881ea7b2ee6d563e6940f4362e26604f'
+ '382ab1774b458a366deac45e38173147cc42f5edbbfb6b93e905c59c5c4abb46')
prepare() {
mkdir -p build
@@ -45,6 +47,7 @@ prepare() {
patch -p1 -i ../WEBRTC-7857.diff
patch -p1 -i ../qtwebengine-ffmpeg4.patch
patch -p1 -i ../fix-building-with-system-icu.diff
+ patch -p1 -i ../QTBUG-86018.patch
}
build() {
diff --git a/QTBUG-86018.patch b/QTBUG-86018.patch
new file mode 100644
index 000000000000..9effe79ab7ca
--- /dev/null
+++ b/QTBUG-86018.patch
@@ -0,0 +1,37 @@
+diff --git a/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py b/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py
+index f75e25fd23f..7e0767e951a 100755
+--- a/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py
++++ b/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py
+@@ -45,6 +45,19 @@ from utilities import abs
+
+ from blinkbuild.name_style_converter import NameStyleConverter
+
++def modify_file(path, prefix_lines, suffix_lines, replace_list=[]):
++ prefix_lines = map(lambda s: s + '\n', prefix_lines)
++ suffix_lines = map(lambda s: s + '\n', suffix_lines)
++ with open(path, 'r') as f:
++ old_lines = f.readlines()
++ for i in range(len(old_lines)):
++ for src, dest in replace_list:
++ old_lines[i] = old_lines[i].replace(src, dest)
++ new_lines = prefix_lines + old_lines + suffix_lines
++ with open(path, 'w') as f:
++ f.writelines(new_lines)
++
++
+ assert len(sys.argv) == 4 or len(sys.argv) == 5
+
+ inputFile = abs(sys.argv[1])
+@@ -115,3 +128,9 @@ print >>outputHFile, '#define %s' % headerGuard
+ print >>outputHFile, outputHContents
+ print >>outputHFile, '#endif // %s' % headerGuard
+ outputHFile.close()
++
++common_replace_list = [(inputRoot + '.hh',
++ inputRoot + '.h')]
++modify_file(
++ outputCpp, [], [],
++ replace_list=common_replace_list)
+--
+cgit v1.2.1
+