summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan R Beste2021-01-16 15:53:26 -0600
committerDan R Beste2021-01-16 15:53:26 -0600
commita7259b022db1f715980b7aff6b1e5c27fbbb3316 (patch)
treef688320e162e8f231501d3799e2e86c58543f8be
parentfb5734f67d4d16c8644f9304a6fa506238c6d20e (diff)
downloadaur-a7259b022db1f715980b7aff6b1e5c27fbbb3316.tar.gz
upgpkg: nim-git 11.4.2.r591.44ceefa9f-1
Updates to nim-git's PKGBUILD
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD75
2 files changed, 73 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 337af086b4f0..a333eb9e3bcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = nim-git
- pkgdesc = Nim is a compiled, garbage-collected systems programming language with a design that focuses on efficiency, expressiveness, and elegance (in that order of priority).
- pkgver = 0.19.4.r1821.d24585c49
+ pkgdesc = Nim is a statically typed compiled systems programming language. It combines successful concepts from mature languages like Python, Ada and Modula. Its design focuses on efficiency, expressiveness, and elegance (in that order of priority).
+ pkgver = 1.4.2.r591.44ceefa9f
pkgrel = 1
epoch = 1
- arch = i686
arch = x86_64
groups = nim
makedepends = git
+ backup = etc/nim/config.nims
+ backup = etc/nim/nim.cfg
+ backup = etc/nim/nimdoc.cfg
+ backup = etc/nim/nimdoc.tex.cfg
+ backup = etc/nim/rename.rules.cfg
source = git+https://github.com/nim-lang/Nim
- source = git+https://github.com/nim-lang/Nim.wiki
source = git+https://github.com/nim-lang/csources
source = git+https://github.com/nim-lang/nimble
source = makepkg-conf.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = 9d73290e81a2e2a79f7bb8058d47854d90ba9301dda1bee107294e2d82f631bf
pkgname = nim-git
@@ -46,3 +48,18 @@ pkgname = nimpretty-git
provides = nimpretty
conflicts = nimpretty
+pkgname = nimfind-git
+ pkgdesc = Nimfind is a tool that helps to give editors IDE like capabilities.
+ url = https://github.com/nim-lang/Nim
+ license = MIT
+ provides = nimfind
+ conflicts = nimfind
+
+pkgname = nim-gdb-git
+ pkgdesc = GDB pretty printing for Nim language.
+ url = https://github.com/nim-lang/Nim
+ license = MIT
+ depends = gdb
+ provides = nim-gdb
+ conflicts = nimp-gdb
+
diff --git a/PKGBUILD b/PKGBUILD
index 6624742a9ec1..59f580e2b91f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,34 +7,40 @@
# Contributor: Zion Nimchuk <zionnimchuk@gmail.com>
pkgbase='nim-git'
-pkgname=('nim-git' 'nimble-git' 'nimsuggest-git' 'nimpretty-git')
-pkgdesc='Nim is a compiled, garbage-collected systems programming language with a design that focuses on efficiency, expressiveness, and elegance (in that order of priority).'
+pkgname=('nim-git' 'nimble-git' 'nimsuggest-git' 'nimpretty-git' 'nimfind-git' 'nim-gdb-git')
+pkgdesc='Nim is a statically typed compiled systems programming language. It combines successful concepts from mature languages like Python, Ada and Modula. Its design focuses on efficiency, expressiveness, and elegance (in that order of priority).'
epoch=1
-pkgver=0.19.4.r1821.d24585c49
+pkgver=1.4.2.r591.44ceefa9f
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('x86_64')
groups=('nim')
+backup=(
+ 'etc/nim/config.nims'
+ 'etc/nim/nim.cfg'
+ 'etc/nim/nimdoc.cfg'
+ 'etc/nim/nimdoc.tex.cfg'
+ 'etc/nim/rename.rules.cfg'
+)
makedepends=('git')
source=(
'git+https://github.com/nim-lang/Nim'
- 'git+https://github.com/nim-lang/Nim.wiki'
'git+https://github.com/nim-lang/csources'
'git+https://github.com/nim-lang/nimble'
'makepkg-conf.patch'
)
sha256sums=(
- 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP'
'9d73290e81a2e2a79f7bb8058d47854d90ba9301dda1bee107294e2d82f631bf'
)
_tag() {
- # Describes the most recent tag
- git describe --abbrev=0 origin/master
+ # Grab the most recent non-annotated tag:
+ git tag | grep -E '^v' | sort | tail -1
}
_revision() {
# Count revisions made to HEAD since master:
- git rev-list --count origin/master...HEAD
+ git rev-list --count $(_tag)..HEAD
}
_commit() {
@@ -77,11 +83,16 @@ build() {
cd -
# Build a release version of the "koch" maintenance program:
- ./bin/nim c -d:release koch
+ ./bin/nim c -d:release --skipUserCfg --skipParentCfg koch
# Build a release version of the nim compiler:
- ./koch boot -d:release -d:nativeStacktrace
+ ./koch boot \
+ -d:nativeStacktrace \
+ -d:release \
+ -d:useGnuReadline \
+ --skipUserCfg \
+ --skipParentCfg
# Build nimsuggest, nimgrep, and nimpretty:
- ./koch tools
+ ./koch tools -d:release --skipUserCfg --skipParentCfg
# Build nimrtl.nim:
cd lib
@@ -105,14 +116,9 @@ package_nim-git() {
# Docs
install -dm 755 "${pkgdir}/usr/share/doc/nim"
cp -dpr --no-preserve=ownership \
- examples doc/* \
+ doc/* \
-t "${pkgdir}/usr/share/doc/nim"
- # Docs: Wiki
- cp -dpr --no-preserve=ownership \
- "${srcdir}/Nim.wiki" \
- "${pkgdir}/usr/share/doc/nim/wiki"
-
# Nim
./koch install "${pkgdir}"
install -Dm 755 bin/{nim,nimgrep} -t "$pkgdir/usr/bin"
@@ -174,23 +180,44 @@ package_nimble-git() {
}
package_nimsuggest-git() {
- pkgdesc="Nimsuggest is a tool that helps to give editors IDE like capabilities."
- url="https://github.com/nim-lang/nimsuggest"
+ pkgdesc='Nimsuggest is a tool that helps to give editors IDE like capabilities.'
+ url='https://github.com/nim-lang/nimsuggest'
license=('MIT')
provides=('nimsuggest')
conflicts=('nimsuggest')
- install -Dm 755 "Nim/bin/nimsuggest" -t "${pkgdir}/usr/bin"
+ install -Dm 755 'Nim/bin/nimsuggest' -t "${pkgdir}/usr/bin"
}
package_nimpretty-git() {
- pkgdesc="Standard tool for pretty printing."
- url="https://github.com/nim-lang/Nim/tree/devel/nimpretty"
+ pkgdesc='Standard tool for pretty printing.'
+ url='https://github.com/nim-lang/Nim/tree/devel/nimpretty'
license=('MIT')
provides=('nimpretty')
conflicts=('nimpretty')
- install -Dm 755 "Nim/bin/nimpretty" -t "${pkgdir}/usr/bin"
+ install -Dm 755 'Nim/bin/nimpretty' -t "${pkgdir}/usr/bin"
+}
+
+package_nimfind-git() {
+ pkgdesc='Nimfind is a tool that helps to give editors IDE like capabilities.'
+ url='https://github.com/nim-lang/Nim'
+ license=('MIT')
+ provides=('nimfind')
+ conflicts=('nimfind')
+
+ install -Dm 755 'Nim/bin/nimfind' -t "${pkgdir}/usr/bin"
+}
+
+package_nim-gdb-git() {
+ pkgdesc='GDB pretty printing for Nim language.'
+ url='https://github.com/nim-lang/Nim'
+ license=('MIT')
+ depends=('gdb')
+ provides=('nim-gdb')
+ conflicts=('nimp-gdb')
+
+ install -Dm 755 'Nim/bin/nim-gdb' -t "${pkgdir}/usr/bin"
}
# vim: sw=2 ts=2 et: