summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-05-18 16:49:57 +0200
committerNicola Murino2020-05-18 16:49:57 +0200
commita7277b35a84e72a5d2c29c58c22e8160c55f02ea (patch)
tree5da381c5229319942a525701b2b7ebe58d648334
parente3ab7c98b74138351d2b93e2757c3b99637b46d9 (diff)
downloadaur-a7277b35a84e72a5d2c29c58c22e8160c55f02ea.tar.gz
update to 514+c5f04a5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 287c84e8384b..ce810379a766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-librtmp0
pkgdesc = Toolkit for RTMP streams (mingw-w64)
- pkgver = 2.4
- pkgrel = 9
+ pkgver = 2.4+514+c5f04a5
+ pkgrel = 1
url = http://rtmpdump.mplayerhq.hu/
arch = any
license = GPL2
@@ -15,7 +15,7 @@ pkgbase = mingw-w64-librtmp0
options = !strip
options = !buildflags
options = staticlibs
- source = git://git.ffmpeg.org/rtmpdump#commit=fa8646daeb19dfd12c181f7d19de708d623704c0
+ source = git://git.ffmpeg.org/rtmpdump#commit=c5f04a58fc2aeea6296ca7c44ee4734c18401aa3
source = 0001-Makefile-allow-to-override-some-parameters.patch
source = 0003-Port-to-openssl-1.1.1.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 79323ecbcdad..f574cd082582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-librtmp0
-pkgver=2.4
-pkgrel=9
+pkgver=2.4+514+c5f04a5
+pkgrel=1
pkgdesc="Toolkit for RTMP streams (mingw-w64)"
arch=('any')
url='http://rtmpdump.mplayerhq.hu/'
@@ -9,7 +9,7 @@ license=('GPL2' 'LGPL2.1')
depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-openssl')
makedepends=('mingw-w64-gcc' 'git' 'mingw-w64-environment')
options=('!strip' '!buildflags' 'staticlibs')
-_commit='fa8646daeb19dfd12c181f7d19de708d623704c0'
+_commit='c5f04a58fc2aeea6296ca7c44ee4734c18401aa3'
source=("git://git.ffmpeg.org/rtmpdump#commit=${_commit}"
'0001-Makefile-allow-to-override-some-parameters.patch'
'0003-Port-to-openssl-1.1.1.patch')
@@ -19,13 +19,18 @@ sha256sums=('SKIP'
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd rtmpdump
+
+ echo "2.4+$(git rev-list --count ${_commit})+$(git rev-parse --short ${_commit})"
+}
+
prepare() {
cd "rtmpdump"
patch -Np1 -i "$srcdir/0001-Makefile-allow-to-override-some-parameters.patch"
patch -Np1 -i "$srcdir/0003-Port-to-openssl-1.1.1.patch"
}
-
build() {
for _arch in ${_architectures}; do
unset CPPFLAGS
@@ -34,7 +39,6 @@ build() {
unset LDFLAGS
source mingw-env ${_arch}
- export C_INCLUDE_PATH="/usr/${_arch}/include/openssl"
[[ -d "build-${_arch}" ]] && rm -rf "build-${_arch}"
cp -rf "$srcdir/rtmpdump" "${srcdir}/build-${_arch}"