summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheArtist2017-10-29 14:36:57 +0200
committerTheArtist2017-10-29 14:36:57 +0200
commita7446810975517b06f3efbe9ef2022fff362cf07 (patch)
tree49432dd2ddc43d86929c323c8db8b13b522c6528
downloadaur-a7446810975517b06f3efbe9ef2022fff362cf07.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--void_cast.patch13
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee3e7e370673
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rtl8723au_bt-dkms
+ pkgdesc = Bluetooth driver for RTL8723AE and RTL8723AU
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://www.realtek.com.tw/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = dkms
+ conflicts = rtl8723au_bt
+ options = !strip
+ source = rtl8723au_bt::git+https://github.com/lwfinger/rtl8723au_bt.git
+ source = void_cast.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = rtl8723au_bt-dkms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13796c7cf5ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Agorgianitis Loukas < agorglouk at gmail dot com >
+
+pkgname=rtl8723au_bt-dkms
+_pkgname=${pkgname%-*}
+pkgver=0.1
+pkgrel=1
+pkgdesc="Bluetooth driver for RTL8723AE and RTL8723AU"
+arch=('any')
+url="http://www.realtek.com.tw/"
+license=('GPL')
+depends=('dkms')
+conflicts=("${_pkgname}")
+makedepends=('git')
+options=(!strip)
+source=("$_pkgname::git+https://github.com/lwfinger/rtl8723au_bt.git"
+ "void_cast.patch")
+sha256sums=('SKIP' 'SKIP')
+
+build() {
+ cd "${srcdir}/${_pkgname}/"
+ git checkout kernel
+ patch -p1 < "${srcdir}/void_cast.patch"
+ rm -fr .git* readme.txt
+}
+
+package() {
+ instdir="$pkgdir/usr/src/$_pkgname-$pkgver"
+ install -dm755 "$instdir"
+ cp -r ${_pkgname}/* ${instdir}/
+}
diff --git a/void_cast.patch b/void_cast.patch
new file mode 100644
index 000000000000..a8cdf1a70848
--- /dev/null
+++ b/void_cast.patch
@@ -0,0 +1,13 @@
+diff --git a/btusb.c b/btusb.c
+index 2e55325..29479ff 100644
+--- a/btusb.c
++++ b/btusb.c
+@@ -1744,7 +1744,7 @@ static int inject_cmd_complete(struct hci_dev *hdev, __u16 opcode)
+ evt->ncmd = 0x01;
+ evt->opcode = cpu_to_le16(opcode);
+
+- *skb_put(skb, 1) = 0x00;
++ *(unsigned char*)skb_put(skb, 1) = 0x00;
+
+ bt_cb(skb)->pkt_type = HCI_EVENT_PKT;
+